Author Topic: "XMPlay has stopped working"  (Read 3119 times)

bornyank1

  • Posts: 36
"XMPlay has stopped working"
« on: 3 Nov '10 - 05:09 »
All,

I just added some music to the XMPlay library and playlist via the context menu in Windows Explorer, when XMPlay crashed. Now, whenever I attempt to start the program, I get an "XMPlay has stopped working" message, and Windows closes it. I tried restarting, and tried downloading the program again and replacing the contents of my XMPlay program folder with whatever comes in the zip file, but that didn't help, either?

Should I just uninstall and reinstall? I've been using the program for years, and never encountered this problem before. If I have to do that, I don't want to lose my plugins and settings, so is there anything I can do to save those?

saga

  • Posts: 2179
Re: "XMPlay has stopped working"
« Reply #1 on: 3 Nov '10 - 07:52 »
Maybe there's a corrupted file preventing XMPlay from starting. You can verify that by temporally moving the xmplay.library and xmplay.pls files (they are either in %APPDATA%\XMPlay or in your XMPlay directory). If XMPlay starts normally again,there is most likely a troublesome file in there. You could try removing the recently added files one by one from xmplay.pls.

andy2004

  • Posts: 12
Re: "XMPlay has stopped working"
« Reply #2 on: 26 Apr '12 - 17:19 »
I'm getting the same messeage, but xmplay has never crashed, when i click the X button to close xmplay when i no long want to listen to music that message always comes up.
i've moved the folder and tested same thing, moved just xmplay, and 2 of the .dll files in_mp3.dll and in_mp3pro.dll and no other others, it runs fine, it created 3 files ,xmplay.ini, xmplay.library and xmplay.pls here is a list when it shows the window.
just tried xmplay and no other files in the folder and just after it created the xmplay.ini and xmplay.pls the window appeared again.

Xmplay version 3.6.0.55 running windows 7 sp1 x64

Problem signature:
  Problem Event Name:   APPCRASH
  Application Name:   xmplay.exe
  Application Version:   3.6.0.55
  Application Timestamp:   4f676e78
  Fault Module Name:   ISApExt32.dll_unloaded   used by inksaver? yes i use inksaver dont know why this would be used by xmplay though.
  Fault Module Version:   0.0.0.0
  Fault Module Timestamp:   4e1921f4
  Exception Code:   c0000005
  Exception Offset:   726b9c06
  OS Version:   6.1.7601.2.1.0.256.1
  Locale ID:   2057
  Additional Information 1:   3f3f
  Additional Information 2:   3f3f1e63d33dcb1a1f89af8be6416f1e
  Additional Information 3:   be6c
  Additional Information 4:   be6c2d3f2faa1dbf635051302a8dfe48

killing isapext32.dll process and running and then quitting xmplay and no popup window. however i dont know how it will effect the inksaver program. erm... as i'm using a 64bit wondering if i really need the 32bit dll running in order for inksaver to run and print properly. guess i could always uninstall inksaver.
« Last Edit: 26 Apr '12 - 17:28 by andy2004 »

Ian @ un4seen

  • Administrator
  • Posts: 20389
Re: "XMPlay has stopped working"
« Reply #3 on: 27 Apr '12 - 15:55 »
I'm not familiar with the "inksaver" software, but I guess it hooks into all processes. To hopefully get some clues on why it's crashing with XMPlay, please provide a "dump" file for the crash. You can have Windows generate dump files (in your user "AppData\Local\CrashDumps" directory) by applying this "localdumps-full" registry entry...

   www.un4seen.com/stuff/localdumps.zip

Please use the latest "stuff" and remove all plugins (to reduce the variables) when generating the dump file, ie. just have XMPLAY.EXE alone in the directory...

   www.un4seen.com/stuff/xmplay.exe

Once you have a dump file, you can upload it (compress it first as it could could be quite large) to have a look at here...

   ftp.un4seen.com/incoming/

You can use the "localdumps-off" registry file to disable the dump file generation afterwards.

andy2004

  • Posts: 12
Re: "XMPlay has stopped working"
« Reply #4 on: 27 Apr '12 - 16:30 »
currently i have disabled the 32bit version of the inksaver and xmplay seems to be working fine, when closing i no longer get the xmplay has stopped working. inksaver is a small commerical program to help use less ink on the printer, via some optimizations of the data your printing.
I will need to rerun the 32bit .dll to get the error message back up. but all the time the 32bit version is disabled the program is still working as i just printed a page up, with no problems. i've downloaded the localdump.zip and the newest xmplay.exe and will as requested create a dump file and upload.

andy2004

  • Posts: 12
Re: "XMPlay has stopped working"
« Reply #5 on: 28 Apr '12 - 12:38 »
uploaded the crash dump file, maybe you can figure out why, to get around the issue myself i've disabled the 32bit dll file.