Author Topic: 3.8 reports, queries and bugs  (Read 122250 times)

Dotpitch

  • Posts: 2870
3.8 reports, queries and bugs
« on: 23 Dec '13 - 21:19 »
3.8 is here, just before Christmas again :). Thanks Ian! Please gather all questions and problems in this thread. And enjoy your XMPlaymas! ;)



Changelog:
  • Separation of tracks into individual subsongs/cues, and unseparation back the other way
  • Subsong info added to library ("subsongs" column) and track info window
  • Random playback mode can be applied to subsongs too
  • "%subsong" and "%subsongs" search term options added
  • Support for tag names in search terms
  • Playlist processing of CUE files
  • Support for remarks in CUE files
  • Soundtracker MOD support
  • Looped OGG support
  • Loop limiting by playback time
  • "Go to time" shortcut to jump to a time position (aka "jump to time")
  • Selection extension page up/down shortcuts
  • Quicker access to file writing options via track right-click menu
  • Support for "Content-Disposition" header filename when saving a streamed file
  • "Year" track info replaced/expanded to "Date"
  • Option to have XMPlay in both the taskbar and tray
  • Taskbar title scrolling
  • Option to replace the playlist when playing tracks from the library
  • Track info option added to info window right-click menu
  • Info window height limit for auto-resizing
  • Archive file URLs will have all of their contents added to the playlist when opened
  • Improved support for drag'n'dropping between the playlist and library and other XMPlay instances
  • Extended playlist filename display mode can optionally include the full paths
  • "closetrack" and "closelist" command-line options to close at the end of the track or playlist
  • Automatic use of the backup if the library file gets corrupted
  • Option to apply title formatting to Winamp plugins removed (now always on)
  • ZIP plugin added to the XMPlay package
  • Skinning enhancements including alpha channel support (see skinning kit)
« Last Edit: 23 Dec '13 - 21:35 by Dotpitch »

saga

  • Posts: 2164
Re: 3.8 reports, queries and bugs
« Reply #1 on: 23 Dec '13 - 22:44 »
Seems like the last-minute loop time limit option might have broken normal looping. I've been listening to the same module for ten minutes now, not realizing that it was supposed to fade out 7 minutes ago... :D Settings are the same as they have always been, i.e. loop=auto, limit isn't checked, 0 mins.

Edit: Nevermind, this might have been a problem with the last 3.7 beta version instead. 3.8 doesn't seem to have the problem.
« Last Edit: 24 Dec '13 - 15:03 by saga »

winner

  • Posts: 260
Re: 3.8 reports, queries and bugs
« Reply #2 on: 23 Dec '13 - 23:28 »
Though mentioned in the text file on the change log, I just downloaded the XMPlay38 package and XMP-ZIP.DLL was not included.

Kaminari

  • Posts: 4
Re: 3.8 reports, queries and bugs
« Reply #3 on: 24 Dec '13 - 00:46 »
Upon launching XMP 3.8, the Delix plugin displays an error message ("You need at least XMPlay version 3.4.0.5") although that doesn't prevent it from working after closing the warning. Had no such issue with prior versions (including the latest 3.7 betas).

saga

  • Posts: 2164
Re: 3.8 reports, queries and bugs
« Reply #4 on: 24 Dec '13 - 01:23 »
That's an issue with the Delix plugin (the XMPlay API has been updated); hopefully there will be an updated version of the plugin soon.

Red Frog

  • Posts: 2
Re: 3.8 reports, queries and bugs
« Reply #5 on: 24 Dec '13 - 03:18 »
Just FYI, if anybody is like me and runs into a situation where XMP keeps opening directly to your system tray, change the "StartInTray=" line in your xmplay.ini. I was having some trouble finding an option for this in the gui but located it (somewhat) more quickly manually. I don't think this option was there before, or if it was maybe it wasn't functioning correctly or was already set to 0.

I actually came here to ask about it but managed to fix it before I got around to finishing this post.   ;D

Dotpitch

  • Posts: 2870
Re: 3.8 reports, queries and bugs
« Reply #6 on: 24 Dec '13 - 09:45 »
Just FYI, if anybody is like me and runs into a situation where XMP keeps opening directly to your system tray, change the "StartInTray=" line in your xmplay.ini. I was having some trouble finding an option for this in the gui but located it (somewhat) more quickly manually. I don't think this option was there before, or if it was maybe it wasn't functioning correctly or was already set to 0.
'StartInTray' is a Secret Setting and is not accessible in the GUI, so you've found the right way to fix it :).

Elrinth

  • Posts: 126
Re: 3.8 reports, queries and bugs
« Reply #7 on: 24 Dec '13 - 09:51 »
When copying in 3.8 exe Delix plugin starts complaining during startup: You need atleast XMPlay version 3.4.0.5.
Anyone else?


Different notice: Attached visual studio 2013 just-in-time debugger to a crashed xmplay which was streaming a web radio. It instantly complain on xmp-gme.dll for some reason?
Seem it crashes no matter what I do... I'll try a blank xmplay. (no songs)
Seems okay without playing anything... seems okay wiht only 2 ogg songs in playlist, it was crowded with mp3, flac, ogg before, maybe 3-400 songs.
Here is dr watson crashlog from 1st crash: http://pastebin.com/HSAzudXQ

Well I removed delix and gme until authors will update them for the latest xmp.
AWESOME work with 3.8 btw!

Oh and merry XMAS!
[spoiler]https://dl.dropboxusercontent.com/u/5145312/pics/WP_20131224_002.jpg[/spoiler]
« Last Edit: 24 Dec '13 - 13:16 by Elrinth »

Dotpitch

  • Posts: 2870
Re: 3.8 reports, queries and bugs
« Reply #8 on: 24 Dec '13 - 10:02 »
When copying in 3.8 exe Delix plugin starts complaining during startup: You need atleast XMPlay version 3.4.0.5. Anyone else?
Actually, yes, that was mentioned 4 posts up! This is known, give Fraggie some time to update the plugin.

rst

  • Posts: 309
Re: 3.8 reports, queries and bugs
« Reply #9 on: 24 Dec '13 - 21:10 »
Error:

You need at least XMPlay version 3.4.0.5

appears when xmplay it is booting.

Dotpitch

  • Posts: 2870
Re: 3.8 reports, queries and bugs
« Reply #10 on: 24 Dec '13 - 21:34 »
Error: You need at least XMPlay version 3.4.0.5 appears when xmplay it is booting.
That was mentioned 6 posts up! This is caused by the Delix plugin and it is known, give Fraggie some time to celebrate Christmas and to update the plugin.

saga

  • Posts: 2164
Re: 3.8 reports, queries and bugs
« Reply #11 on: 24 Dec '13 - 22:42 »
When XMPlay starts up the, Delix plugins tells me that it requires... err, is this kind of repeating? ;D

winner

  • Posts: 260
Re: 3.8 reports, queries and bugs
« Reply #12 on: 25 Dec '13 - 00:34 »
Though mentioned in the text file on the change log, I just downloaded the XMPlay38 package and XMP-ZIP.DLL was not included.
Looks like this has been corrected. Great!

Gaumon

  • Posts: 3
Re: 3.8 reports, queries and bugs
« Reply #13 on: 25 Dec '13 - 12:24 »
Hmm, since version 3.8 the Loop function seems to be broken, or rather the 'Auto-loop any track ending with sound'-function.
The same track (an .ogg-file) played in version 3.7 all times repeated, since XMPlay 3.8 never!  ???
I've checked in the options: 'Loop' to auto, 'Limit' is unchecked and all set to 0, like it in version 3.7 was. This also happens to other files (.mp3, .acc etc.).

Note:  Beforehand, the problem seems ONLY to affect the .ogg-files, no other audio files.
          I've tested it with the same .ogg-file on a clean 'install' of XMPlay 3.8  &  3.7, both with the same settings, no plugins.
          Version 3.7 works great, version 3.8 works NOT.  Any ideas to fix it?
« Last Edit: 25 Dec '13 - 18:50 by Gaumon »

piovrauz

  • Posts: 967
Re: 3.8 reports, queries and bugs
« Reply #14 on: 25 Dec '13 - 13:51 »
Delix... no, wait, I already reported it and Ian and Fraggie are working on it! XD

r

  • Posts: 183
Re: 3.8 reports, queries and bugs
« Reply #15 on: 25 Dec '13 - 18:48 »
Absolutely lovin' the new "Separate subsongs" context menu entry!

Would it be possible to automatically do this when adding files to the playlist?  Perhaps a setting in "Options and Stuff"?

piovrauz

  • Posts: 967
Re: 3.8 reports, queries and bugs
« Reply #16 on: 25 Dec '13 - 19:53 »
Absolutely lovin' the new "Separate subsongs" context menu entry!

Would it be possible to automatically do this when adding files to the playlist?  Perhaps a setting in "Options and Stuff"?

+2 (me, myself)
As an option, so one could save the setting for specific formats only... ;)

gul

  • Posts: 12
Re: 3.8 reports, queries and bugs
« Reply #17 on: 27 Dec '13 - 11:57 »
First of all, sorry for my bad and short English.
The problem is that XMPlay 3.8 not play OGG streams as:
http://amp.cesnet.cz:8000/cro-d-dur-256.ogg
http://live.slovakradio.sk:8000/Klasika_256.ogg
http://stream3.rozhlas.cz:8000/jazz_high.ogg
http://stream-tx1.radioparadise.com:9000/rp_192.ogg
And XMPlay 3.7.0.44 plays them perfectly.
No problems with Flacs streams.
Thanks for your attention and effort.
Merry Christmas and Happy New Year.
Best regards

piovrauz

  • Posts: 967
Re: 3.8 reports, queries and bugs
« Reply #18 on: 27 Dec '13 - 12:12 »
I can confirm it, those stream are stuck on buffering. Could it be related to the looping .ogg got recently?

r

  • Posts: 183
Re: 3.8 reports, queries and bugs
« Reply #19 on: 27 Dec '13 - 17:05 »
First of all, sorry for my bad and short English.
The problem is that XMPlay 3.8 not play OGG streams as:
http://amp.cesnet.cz:8000/cro-d-dur-256.ogg
http://live.slovakradio.sk:8000/Klasika_256.ogg
http://stream3.rozhlas.cz:8000/jazz_high.ogg
http://stream-tx1.radioparadise.com:9000/rp_192.ogg
And XMPlay 3.7.0.44 plays them perfectly.
No problems with Flacs streams.
Thanks for your attention and effort.
Merry Christmas and Happy New Year.
Best regards

I tried the Rozhlas link and it worked for me and I'm on 3.8.  Try restarting XMPlay and see if it works.  Also if you are using xmp-ffmpeg, disable that.

purenoise

  • Posts: 51
Re: 3.8 reports, queries and bugs
« Reply #20 on: 27 Dec '13 - 17:26 »
BUG:

 - keep hanging on fast forward...

worked fine on 3.7, 3.6

gul

  • Posts: 12
Re: 3.8 reports, queries and bugs
« Reply #21 on: 27 Dec '13 - 17:29 »
I tried the Rozhlas link and it worked for me and I'm on 3.8.  Try restarting XMPlay and see if it works.  Also if you are using xmp-ffmpeg, disable that.

No luck, sorry. xmp-ffmpeg not installed et all.

Are you sure you've opened the ogg stream?

Thanks

Edit: I added more detail in the section quoted.
« Last Edit: 27 Dec '13 - 19:52 by gul »

purenoise

  • Posts: 51
Re: 3.8 reports, queries and bugs
« Reply #22 on: 27 Dec '13 - 17:33 »
Playing local mp3 media, and
at forwarding xmplay hand and i
need to kill the process.

gul

  • Posts: 12
Re: 3.8 reports, queries and bugs
« Reply #23 on: 27 Dec '13 - 17:52 »
The problem I am reporting is only on ogg streams

purenoise

  • Posts: 51
Re: 3.8 reports, queries and bugs
« Reply #24 on: 27 Dec '13 - 18:15 »
Ohh..., i thought topic is for all bug reports...