Author Topic: 3.8 reports, queries and bugs  (Read 124781 times)

raina

  • Posts: 1163
Re: 3.8 reports, queries and bugs
« Reply #250 on: 16 Dec '14 - 13:51 »
I uploaded unseekable.flac, a sample from an album full of these. The track lengths are shown only after playing the tracks and even then, on subsequent replays, they remain unseekable.

piovrauz

  • Posts: 967
Re: 3.8 reports, queries and bugs
« Reply #251 on: 16 Dec '14 - 14:21 »
I'm interested in those dodgy flacs.
Shouldn't .flac be seekable "by design"?

Ian @ un4seen

  • Administrator
  • Posts: 20400
Re: 3.8 reports, queries and bugs
« Reply #252 on: 16 Dec '14 - 17:11 »
I may have missed something, and I'm only saying this now because I haven't figured it out, .. it seems like title scrolling has been broken for several versions.

That's strange. What "Scroll title" setting do you have in the "Titles" options page, and does changing it make any difference? Also, in case the problem is skin-specific (eg. title alignment), does it happen with the default skin?

I uploaded unseekable.flac, a sample from an album full of these. The track lengths are shown only after playing the tracks and even then, on subsequent replays, they remain unseekable.

The file doesn't include length information (it's set to 0), so the length is only known once the file has been played. I'll update the FLAC plugin to fallback on the playlist entry's length value in that case tomorrow. I just noticed that there is a bug in the plugin system's playlist entry length retrieval option, so an XMPlay update will be needed too.

xaos

  • Posts: 172
Re: 3.8 reports, queries and bugs
« Reply #253 on: 16 Dec '14 - 19:13 »
well, i missed something .. figures .. it's a dropbox not a checkbox .. so scrolling isn't broken, my bad. thanx.

winner

  • Posts: 260
Re: 3.8 reports, queries and bugs
« Reply #254 on: 17 Dec '14 - 00:11 »
I may have missed something, and I'm only saying this now because I haven't figured it out, .. it seems like title scrolling has been broken for several versions.

That's strange. What "Scroll title" setting do you have in the "Titles" options page, and does changing it make any difference? Also, in case the problem is skin-specific (eg. title alignment), does it happen with the default skin?
Title bar scrolling does not work for me, with default skin and Rated Wood skin. I'm sure that scrolling worked previously on my system with these two skins. Taskbar scrolling works by itself and when "both" is selected. Title bar scrolling works in the Flat.II.Red skin.

Jimmy Neutron

  • Posts: 473
Re: 3.8 reports, queries and bugs
« Reply #255 on: 17 Dec '14 - 01:47 »
As I played with it, I realized that by leaving the songs alone, I got the tray bubble when the new track starts.  But, if I press the next button, there is no tray bubble when the new track starts.  After playing with it for more time than I care to admit, I figured out the issue.... If the main XMPlay window has focus, there will not be a tray bubble. If the main window does not have focus, there will be a tray bubble.  Oh, and if the skin is minimized, using the right-click on the system tray icon to go to next track will show a tray bubble.

This is stuff version 28 using any skin on Win 8.1 with icon always showing in system tray.

Maybe I don't understand how it is supposed to work?




Ian @ un4seen

  • Administrator
  • Posts: 20400
Re: 3.8 reports, queries and bugs
« Reply #256 on: 17 Dec '14 - 14:30 »
well, i missed something .. figures .. it's a dropbox not a checkbox .. so scrolling isn't broken, my bad. thanx.

It did used to be a checkbox, but that was replaced with the dropbox in 3.8 to include the taskbar scrolling option. The previous setting should have been maintained when upgrading to 3.8, but perhaps it wasn't.

Title bar scrolling does not work for me, with default skin and Rated Wood skin. I'm sure that scrolling worked previously on my system with these two skins. Taskbar scrolling works by itself and when "both" is selected. Title bar scrolling works in the Flat.II.Red skin.

Is the title definitely longer than will fit in the title bar? The title will only scroll when that is the case, and the "Flat.II" skin does have quite a narrow title bar.

As I played with it, I realized that by leaving the songs alone, I got the tray bubble when the new track starts.  But, if I press the next button, there is no tray bubble when the new track starts.  After playing with it for more time than I care to admit, I figured out the issue.... If the main XMPlay window has focus, there will not be a tray bubble. If the main window does not have focus, there will be a tray bubble.  Oh, and if the skin is minimized, using the right-click on the system tray icon to go to next track will show a tray bubble.

This is stuff version 28 using any skin on Win 8.1 with icon always showing in system tray.

Maybe I don't understand how it is supposed to work?

That sounds like you have XMPlay in the tray rather than the taskbar, or in both. Normally tray titles will only be displayed when XMPlay is minimized to the tray, but if XMPlay is always in the tray, then the tray titles will indeed only be shown when XMPlay doesn't have focus (as XMPlay's title bar should be visible when it has focus).

Ian @ un4seen

  • Administrator
  • Posts: 20400
Re: 3.8 reports, queries and bugs
« Reply #257 on: 17 Dec '14 - 16:44 »
The file doesn't include length information (it's set to 0), so the length is only known once the file has been played. I'll update the FLAC plugin to fallback on the playlist entry's length value in that case tomorrow. I just noticed that there is a bug in the plugin system's playlist entry length retrieval option, so an XMPlay update will be needed too.

Here are the aforementioned FLAC plugin and XMPlay updates...

   www.un4seen.com/stuff/xmp-flac.dll
   www.un4seen.com/stuff/xmplay.exe

winner

  • Posts: 260
Re: 3.8 reports, queries and bugs
« Reply #258 on: 17 Dec '14 - 23:46 »
Title bar scrolling does not work for me, with default skin and Rated Wood skin. I'm sure that scrolling worked previously on my system with these two skins. Taskbar scrolling works by itself and when "both" is selected. Title bar scrolling works in the Flat.II.Red skin.
Is the title definitely longer than will fit in the title bar? The title will only scroll when that is the case, and the "Flat.II" skin does have quite a narrow title bar.
Sure enough, I hadn't picked a song with a long enough title string. Scrolling is in fact working still. Sorry there!

Muxson

  • Posts: 39
Re: 3.8 reports, queries and bugs
« Reply #259 on: 25 Dec '14 - 10:19 »
I just downloaded the latest updates but when running a Check for updates, it tells me there are new ones. Is that a bug or is it me?

piovrauz

  • Posts: 967
Re: 3.8 reports, queries and bugs
« Reply #260 on: 25 Dec '14 - 11:35 »
Just checked with XMPlay 3.8.1, no new update(s) for plugins here.
WMA and ZIP are included in the 3.8.1 release, so it must be on "your side".
The WA vis wrapper (and coverart too) didn't get updates since a long time, so it's strange indeed.
Are you sure you're putting them in the XMPlay directory? sure there aren't duplicates?

winner

  • Posts: 260
Re: 3.8 reports, queries and bugs
« Reply #261 on: 25 Dec '14 - 17:55 »
I just downloaded the latest updates but when running a Check for updates, it tells me there are new ones. Is that a bug or is it me?

I got the same popup today and two or three days ago also.

SmartOne

  • Posts: 217
Re: 3.8 reports, queries and bugs
« Reply #262 on: 25 Jan '15 - 20:46 »
Using Winamp plugin NEZplug++ (NSF files, etc.), its "HookWinamp" feature no longer works.  I used to be able to right-click the "Next" button to play the next subsong.  The last XMPlay version that I know this worked was 3.6.0.66.

By the way, the CUE splitting feature is awesome.  If only that could work for NSF files using this Winamp plugin (I know, impossible because you would need more information from the plugin).  Thank you!

Ian @ un4seen

  • Administrator
  • Posts: 20400
Re: 3.8 reports, queries and bugs
« Reply #263 on: 26 Jan '15 - 14:40 »
Using Winamp plugin NEZplug++ (NSF files, etc.), its "HookWinamp" feature no longer works.  I used to be able to right-click the "Next" button to play the next subsong.  The last XMPlay version that I know this worked was 3.6.0.66.

Is the subsong seeking not working with a particular NSF file? What about with this file...

   www.zophar.net/music/nsf/solstice-the-quest-for-the-staff-of-demnos-%5Bsolstice-sanjigen-meikyuu-no-kyoujuu%5D.html

If that file is working, but you have another one that isn't, please upload it to have look at here...

   ftp.un4seen.com/incoming/

SmartOne

  • Posts: 217
Re: 3.8 reports, queries and bugs
« Reply #264 on: 28 Jan '15 - 00:32 »
I'm sorry, false alarm.  I stupidly had two versions of the plugin (different names) loaded, so that must have screwed it up... Still doesn't make complete sense.
« Last Edit: 28 Jan '15 - 00:36 by SmartOne »

TroudhuK

  • Guest
Re: 3.8 reports, queries and bugs
« Reply #265 on: 29 Jan '15 - 21:10 »
There is a new bug (from 3.8.0) to load settings when XMPlay is in a path with non-ANSI characters (eq C:\Données\¤ Portable app ¤\XMPlay). Windows positions are reinitialized...

Ian @ un4seen

  • Administrator
  • Posts: 20400
Re: 3.8 reports, queries and bugs
« Reply #266 on: 30 Jan '15 - 16:11 »
Oh yes, there is indeed a problem with the XMPLAY.INI loading in that case. Here's an update that should fix it...

   www.un4seen.com/stuff/xmplay.exe

Let me know if you still have the problem with that.

TroudhuK

  • Guest
Re: 3.8 reports, queries and bugs
« Reply #267 on: 30 Jan '15 - 18:45 »
Nice, thanks, I remove the read-only attribute for my xmplay.ini (remade because the update made me lost all my previous settings :'()

I also have this bug (for a long time) but I don't know if you are concerned, it's for some types of files (ex: .mid):

(key words: XMP-Delix, no slave players found)

piovrauz

  • Posts: 967
Re: 3.8 reports, queries and bugs
« Reply #268 on: 30 Jan '15 - 20:28 »
Not really a bug, but some unwanted behaviour with a stream: when the track changes the stream resets the playtime in XMPlay main window.
The history of played tracks in the message window gets reset too. It may be the stream behaving strange, but it doesn't seem to change format.
This is the culprit: http://frenchcore24.myetrayz.net:9001/ices. Usually they stream hour long podcasts, so sorry if you don't like the genre (well, mute it).
When it resets it has a moment of silence too, but I don't think it's a buffer issue, nor a connectivity one.
Would it be possible to "fix" this please?

saga

  • Posts: 2179
Re: 3.8 reports, queries and bugs
« Reply #269 on: 30 Jan '15 - 23:10 »
TroudhuK: That's not a bug, you obviously just set up xmp-delix incorrectly. If you don't use the plugin, delete it, and if you actually do intend to use it, re-download the zip package and make sure that all files in the package are extracted into the same directory. xmp-delix.dll alone is not enough, it requires xmp-delix.dat to reside in the same directory.

piovrauz

  • Posts: 967
Re: 3.8 reports, queries and bugs
« Reply #270 on: 30 Jan '15 - 23:58 »
The zip plugin is required too, as the message tells ;)

saga

  • Posts: 2179
Re: 3.8 reports, queries and bugs
« Reply #271 on: 31 Jan '15 - 00:10 »
That's part of the official XMPlay package though, so if that's missing, they did something *really* wrong.

TroudhuK

  • Guest
Re: 3.8 reports, queries and bugs
« Reply #272 on: 31 Jan '15 - 00:30 »
Ok I didn't remember that I already found the cause, it's also a problem of special characters in path. Thanks for trying to help me but I can read, of course if it was a problem of xmp-delit.dat or xmp-zip.dll, I would have fixed it  ::)

Dotpitch

  • Posts: 2871
Re: 3.8 reports, queries and bugs
« Reply #273 on: 31 Jan '15 - 10:01 »
Ok I didn't remember that I already found the cause, it's also a problem of special characters in path.
So is it fixed with the latest stuff version?

Not really a bug, but some unwanted behaviour with a stream: when the track changes the stream resets the playtime in XMPlay main window. ... It may be the stream behaving strange, but it doesn't seem to change format.
From what you describe, it sounds like the stream is actually reset. I can't get the stream the play reliably over here unfortunately.

TroudhuK

  • Guest
Re: 3.8 reports, queries and bugs
« Reply #274 on: 31 Jan '15 - 11:23 »
Quote
So is it fixed with the latest stuff version?
Nop, I will post about it at the Delix topic.