Author Topic: 3.8 reports, queries and bugs  (Read 124527 times)

Cosworth

  • Posts: 123
Re: 3.8 reports, queries and bugs
« Reply #275 on: 20 Feb '15 - 21:57 »
delete

piovrauz

  • Posts: 967
Re: 3.8 reports, queries and bugs
« Reply #276 on: 21 Feb '15 - 08:52 »
Not really a bug, but some unwanted behaviour with a stream: when the track changes the stream resets the playtime in XMPlay main window. ... It may be the stream behaving strange, but it doesn't seem to change format.
From what you describe, it sounds like the stream is actually reset. I can't get the stream the play reliably over here unfortunately.

Well, indeed the stream has days when it works perfectly and others where it doesn't.
Funny how it started being problematic after a playing perfectly for a good while, so I first tought it was fine itself.
I suppose it's not an XMPlay issue too right now.

nwo.idaho

  • Posts: 5
Re: 3.8 reports, queries and bugs
« Reply #277 on: 27 Feb '15 - 23:58 »
Just downloaded the new .exe (3.8.1.7) and Avira registers the file as a virus. Avira says it's 'TR/Crypt.ZPACK.Gen2'.. Had to go re-download 3.8.1.2 to get going again..

piovrauz

  • Posts: 967
Re: 3.8 reports, queries and bugs
« Reply #278 on: 28 Feb '15 - 09:19 »
Usual false positive. Report to Avira as such. Or get a better AV that does a better job at false positives.
For better info: https://www.virustotal.com/it/file/76496757fa9a326effdc5645f0a4ead02e7cebf07cc263b37c8898f3f540ff7c/analysis/1425115002/
I'd say euristics of some AV doesn't perform well... or that they just put a "virus" label on anything packed (which itself is a legit procedure btw).

saga

  • Posts: 2179
Re: 3.8 reports, queries and bugs
« Reply #279 on: 28 Feb '15 - 18:05 »
Well, they don't say it's a virus. They say it's a generic detection routine that detects files packed with custom executable packers which they cannot unpack. You are the one interpreting it as "ZOMG VIRUS!!!". ;)

piovrauz

  • Posts: 967
Re: 3.8 reports, queries and bugs
« Reply #280 on: 28 Feb '15 - 21:34 »
obviously common folks just see the big red mark? ;)

saga

  • Posts: 2179
Re: 3.8 reports, queries and bugs
« Reply #281 on: 15 Mar '15 - 20:26 »
Caught a nice little crash in xmp-ds while suspending to RAM, which also involved plugging headphones out and in again from my laptop. Uploaded as xmp-ds.7z.

Ian @ un4seen

  • Administrator
  • Posts: 20389
Re: 3.8 reports, queries and bugs
« Reply #282 on: 17 Mar '15 - 18:02 »
I think I see what's happened, and here's an XMPlay update that will hopefully prevent it happening again...

   www.un4seen.com/stuff/xmplay.exe

Let me know if you do still get the problem happening.

saga

  • Posts: 2179
Re: 3.8 reports, queries and bugs
« Reply #283 on: 18 Mar '15 - 18:32 »
A while ago, I fixed S9F behaviour in OpenMPT so that it actually does something sensible with looped samples. That is, when applying S9F next to a note of a looped sample, it will now start from the end of the sample (as before) and actually play the sample backwards (this part is new). Would be great if XMPlay/BASS follows the new implementation.

Tascam 58

  • Posts: 5
Re: 3.8 reports, queries and bugs
« Reply #284 on: 19 Mar '15 - 03:29 »
From time to time I'll check in and grab the latest "stuff" version, pulled in a copy of xmplay [3.8.1.11], all is working well for me except the minimise to system tray option. When minimised, it shows an icon in my system tray and a tab on my taskbar. When I close the app and run a previous stuff version of xmplay [3.8.1.6], minimise drops down to the system tray and clears from the taskbar as I like it to do. I had the same action when trying out xmplay [3.8.1.7] the other week, it would not clear from the taskbar either so I just returned to xmplay [3.8.1.6] my last working [for me] version. Has there been a setting or function change that may be causing this action bearing in mind all other files within my xmplay folder remain unchanged except the latest exe file swap.

Cheers

Jace

  • Posts: 825
Re: 3.8 reports, queries and bugs
« Reply #285 on: 19 Mar '15 - 04:34 »
Just grabbed 3.8.1.11, tray seems to behave as expected. See Options and stuff page "Miscellaneous", what's the "Show in:" dropbox set to on the bottom right corner?

Tascam 58

  • Posts: 5
Re: 3.8 reports, queries and bugs
« Reply #286 on: 19 Mar '15 - 11:41 »
So now I am confused  ???, Jace, I have checked "show in" box and it states "both", this has been changed to "tray" and it is now doing what is says on the tin and runs from the tray in both minimized and maximized modes with no tab on the taskbar which is not the way it was before.

Confusion comes from the fact that I have not changed this "show in" setting for many versions [including some 30+ stuff versions] that I can think of - it has always been set to "show in" both.

I have just swapped in one of my local archive versions xmplay 3.8 [Dec 13] for testing and this does what I thought zmplay had done for a few years - when in full mode [maximized] it shows on taskbar and in tray, when minimized in will hide from taskbar and show only in tray. I have swapped in a random number of versions from xmplay 3.8.0.1 to xmplay 3.8.0.30 including xmplay 3.8.1.0 through to xmplay 3.8.1.6 and the ones I have tried would all appear to exhibit the same behaviour, as in  - [show in both] when in full mode [maximized] it shows on taskbar and in tray, when minimized it will hide from taskbar and show only in tray.

It has only been the last two versions I have grabbed from the site [xmplay 3.8.1.7 and xmplay 3.8.1.11] that this behaviour has changed for me. So my question then would be - with "show in" box set to "both" from version 3.8.0.0 onwards and probably most of 3.7.x.x, has this always been a fault for me, or has something changed recently that has changed the previous minimize and hide from taskbar behaviour when set to show in both

Cheers

« Last Edit: 19 Mar '15 - 14:52 by Tascam 58 »

Ian @ un4seen

  • Administrator
  • Posts: 20389
Re: 3.8 reports, queries and bugs
« Reply #287 on: 19 Mar '15 - 13:24 »
The fact that XMPlay minimized only to the tray when the "Show in" option was set to "both" was actually a little bug; it should remain in the tray and taskbar, as "both" would suggest. That was corrected in a recent update. If you would prefer to minimize only to the tray, that is still possible by right-clicking the minimize button or using a keyboard shortcut (shift+N by default).

Jace

  • Posts: 825
Re: 3.8 reports, queries and bugs
« Reply #288 on: 19 Mar '15 - 14:10 »
Ohhh, I see what you meant now. Yeah, I always keep it in the tray, thus me bein' equally confused.

Tascam 58

  • Posts: 5
Re: 3.8 reports, queries and bugs
« Reply #289 on: 19 Mar '15 - 14:50 »
Yip, happy with both options / explanations given by Ian @ un4seen. So the feature as I thought has actually been a bug all this time - well there you go and there you are, whodah thunk it.

Thanks as always and keep up the excellent work  ;D

kode54

  • Posts: 100
Re: 3.8 reports, queries and bugs
« Reply #290 on: 18 Apr '15 - 03:34 »
yf-nebulae.it is missing some notes from its lead instrument about 40 seconds in.

Ian @ un4seen

  • Administrator
  • Posts: 20389
Re: 3.8 reports, queries and bugs
« Reply #291 on: 20 Apr '15 - 18:15 »
Thanks. It appears to be an issue with an instrument's volume envelope being off but having the "carry" flag set. Here's an update that should fix it...

   www.un4seen.com/stuff/xmplay.exe

kode54

  • Posts: 100
Re: 3.8 reports, queries and bugs
« Reply #292 on: 21 Apr '15 - 01:27 »
Thanks. Awaiting updated BASS for Windows 32 bit and OS X, and hopefully the former will get whitelisted before I release it.

Ian @ un4seen

  • Administrator
  • Posts: 20389
Re: 3.8 reports, queries and bugs
« Reply #293 on: 24 Apr '15 - 17:46 »
Here are updated Windows and OSX BASS versions that include the IT fix above...

   www.un4seen.com/stuff/bass.zip
   www.un4seen.com/stuff/libbass.dylib

kode54

  • Posts: 100
Re: 3.8 reports, queries and bugs
« Reply #294 on: 25 Apr '15 - 09:18 »
Thank you so much. I'll probably hold off on the Windows update for a while, at least until I know you've gotten it whitelisted.

TroudhuK

  • Guest
Re: 3.8 reports, queries and bugs
« Reply #295 on: 10 May '15 - 16:49 »
I found a sound which made XMPlay crash: http://uptobox.com/x9knsrmyjmvd (from KeyGenMusic).

saga

  • Posts: 2179
Re: 3.8 reports, queries and bugs
« Reply #296 on: 10 May '15 - 18:34 »
That's not an XMPlay issue, that's an issue with the V2M plugin. There are two major revisions of the V2M input plugin, so you should see if either version works correctly with this file.

TroudhuK

  • Guest
Re: 3.8 reports, queries and bugs
« Reply #297 on: 10 May '15 - 19:00 »
You're right, found it, thank you. With the oldest one, it plays.

Funzi

  • Guest
Re: 3.8 reports, queries and bugs
« Reply #298 on: 11 May '15 - 13:26 »
Hello i was doing some fuzzing and i encountered this bug on xmPlay. Here is log from WinDbg: http://pastebin.com/r2CDVwAC


Ian @ un4seen

  • Administrator
  • Posts: 20389
Re: 3.8 reports, queries and bugs
« Reply #299 on: 11 May '15 - 13:33 »
From the path used ("...\xmplay37\..."), it looks like you may be using an old XMPlay version? If so, please see if you can reproduce the problem with the current release, and if you can reproduce it, upload the dump file to have a look at here:

   ftp.un4seen.com/incoming/

If it's happening with a particular audio file, please upload that too.