Author Topic: 3.8 reports, queries and bugs  (Read 123933 times)

Ian @ un4seen

  • Administrator
  • Posts: 20339
Re: 3.8 reports, queries and bugs
« Reply #500 on: 14 Sep '17 - 15:39 »
Oops! Here's an update to fix that:

   www.un4seen.com/stuff/xmplay.exe

This update also moves the info window text buffer to the heap (rather than the stack). It's still limited to 40 KB, but at least any overflows won't corrupt the stack now.

saga

  • Posts: 2171
Re: 3.8 reports, queries and bugs
« Reply #501 on: 18 Sep '17 - 16:14 »
Without doubt this module here is corrupted: https://modarchive.org/index.php?request=view_by_moduleid&query=107890
However, it seems that XMPlay may read from some uninitialized memory when decoding the patterns, which it definitely should not do.
If you load this MOD file and some other file(s) alternatingly several times in a row, you should be able to observe in the pattern vis that the content of the first played pattern changes occasionally.

Ian @ un4seen

  • Administrator
  • Posts: 20339
Re: 3.8 reports, queries and bugs
« Reply #502 on: 21 Sep '17 - 16:23 »
Yep, if a MOD file ends in the middle of the pattern data, then XMPlay will currently be repeatedly reading (from memory) the 4 bytes after the end for every row after that. I will sort it for the next update.

sveakul

  • Posts: 13
Re: 3.8 reports, queries and bugs
« Reply #503 on: 10 Oct '17 - 04:28 »
Is it possible to add display values corresponding to "bitrate" and "sample rate" to the optional formatting string choices in the Titles option?

Ian @ un4seen

  • Administrator
  • Posts: 20339
Re: 3.8 reports, queries and bugs
« Reply #504 on: 10 Oct '17 - 18:02 »
Unfortunately, that isn't possible currently because the bitrate and sample rate info isn't retained by XMPlay; it only has that info for the file that is currently playing.

sveakul

  • Posts: 13
Re: 3.8 reports, queries and bugs
« Reply #505 on: 11 Oct '17 - 04:37 »
OK thanks for the info Ian!  Something for the "Wishlist" then  ;)

saga

  • Posts: 2171
Re: 3.8 reports, queries and bugs
« Reply #506 on: 12 Oct '17 - 11:31 »
Has anyone else noticed that XMPlay (for quite a while now) occasionally drags two adjacted playlist entries even though only one of them is visibly selected? I cannot quite tell how to reproduce it because it's random, but it's happening all the time to me - it's rather annoying.