Author Topic: solution for xmpzxtune to not crash when dragging a .sfv file into xmplay?  (Read 857 times)

Elrinth

  • Posts: 130
Hi!

So some of my albums I've grabbed have a .sfv file inside of them. when dragging that .sfv file into xmplay. xmplay crashes complaining on the xmpzxtune plugin and a null error message. is there any way to make xmplay ignore .sfv files?!

I have added a ticket on the sourceforge page, we will see if the author will take measures.
« Last Edit: 11 Aug '16 - 12:03 by Elrinth »

Ian @ un4seen

  • Administrator
  • Posts: 20389
Adding "sfv" to the "Ignore filetypes" setting in the "Playlist" options page should make XMPlay ignore those files.

Elrinth

  • Posts: 130
that works for when dragging the sfv alone or together with other files... but when dragging the whole folder which is containing a m3u (the m3u can be blank) into xmplay, it would still crash and complain on that plugin.

edit 1: seems I'm having problems with all plugins crashing when a folder with a m3u inside is being dragged into xmplay.
cuz i tried disabling the xmpzxtune and it would now complain on some other plugin instead.

edit 2:
I narrowed it down to winamp input plugins!
having any winamp plugin installed for example:
in_ken.dll
or
in_gbs.dll
or
in_nez.dll
xmplay would crash when draggin a folder with a m3u inside of it.
this is also the case with: xmp-zxtune.dll
but the rest of all the xmp-plugins it works fine.

I am using 3.8.2.10 (stuffs version)

I have all my plugins inside a plugins folder except a couple of dlls which need to lie just next to the xmplay.exe such as: bass.dll vorbis.dll libOggFLAC.dll msvcr71.dll mxdrv.dll etc.
maybe that is the problem?
« Last Edit: 11 Aug '16 - 16:54 by Elrinth »

Ian @ un4seen

  • Administrator
  • Posts: 20389
I narrowed it down to winamp input plugins!
having any winamp plugin installed for example:
in_ken.dll
or
in_gbs.dll
or
in_nez.dll
xmplay would crash when draggin a folder with a m3u inside of it.
this is also the case with: xmp-zxtune.dll
but the rest of all the xmp-plugins it works fine.

That's strange. Please ZIP and upload a small folder that you can reproduce the problem with to have a look at here:

   ftp.un4seen.com/incoming/

Elrinth

  • Posts: 130
Ny mapp.zip has been uploaded.

I think the actual problem is that I have too many plugins installed or something
When climbing to 55 .dlls (27.1 MB) is when the crash starts appearing.

can someone else recreate this bug?
simply create a folder, add an empty .m3u file inside the folder. then drag the folder into xmplay.
Make sure you have over 55 .dll files in xmplay.

here I have shared my xmplay folder: https://dl.dropboxusercontent.com/u/5145312/xmplay_wo_soundfonts.zip
i deleted the soundfonts so it wouldn't take up too much space.
« Last Edit: 12 Aug '16 - 09:45 by Elrinth »

Ian @ un4seen

  • Administrator
  • Posts: 20389
I don't seem to be able to reproduce the crash here. Do you happen to have the xmp-vgmstream plugin installed? That had a little bug which resulted in other plugins crashing (see here). The problem appears to have been fixed recently in the plugin's source code, but I'm not sure if an updated build has been released since then.

Elrinth

  • Posts: 130
vgmstream it was indeed!!! thank you

rst

  • Posts: 309
and also 0 Bytes files crash it....