Author Topic: Open & Play takes a long time  (Read 317 times)

asp

  • Posts: 50
Open & Play takes a long time
« on: 12 Oct '18 - 14:56 »
Hello,

Some of my users are reporting that Opening and playing a file takes a long time (around 6-7 seconds). I haven't been able to reproduce the issue, so I don't know if it gets stuck in the open or in the play call. This only happens from time to time, usually when my application hasn't played a file in a few minutes.

This happens with the old DirectSound version and with the new one with WASAPI support.

Does anybody have this issue?

Ian @ un4seen

  • Administrator
  • Posts: 21372
Re: Open & Play takes a long time
« Reply #1 on: 12 Oct '18 - 15:31 »
That sounds like the drive may have gone to sleep or been powered down, and is taking a while to get ready again. If they want to prevent that, the users could try raising (or set to "Never") the "Turn off hard disk after..." setting in the "Power Options" control panel, as described here:

   www.thewindowsclub.com/prevent-hard-drive-going-sleep-windows

If the drives are connected via USB, they may also need to do similar for the USB ports.

asp

  • Posts: 50
Re: Open & Play takes a long time
« Reply #2 on: 16 Oct '18 - 20:09 »
Thanks for your answer.

Unfortunately, it didn't help and my user keeps reporting the issue. Any other ideas?

radio42

  • Posts: 4637
Re: Open & Play takes a long time
« Reply #3 on: 16 Oct '18 - 20:22 »
Can you confirm from what kind of device the user is playing the file?
If it is a network attached storage (NAS) or USB connected device, these might go into sleep mode by their-self after being idle for some time - this could lead to the same effect.

asp

  • Posts: 50
Re: Open & Play takes a long time
« Reply #4 on: 17 Oct '18 - 21:33 »
He is playing the files from the local hard drive.