Author Topic: BASS_ChannelGetAttribute  (Read 423 times)

John F

  • Posts: 3
BASS_ChannelGetAttribute
« on: 10 Jul '19 - 10:39 »
Hi,

I have an issue with latest Bass from stuff when I call

BASS_ChannelGetAttribute(StreamHandle, BASS_ATTRIB_BITRATE, BitRate)

Bass 2.4.14.0 returns BitRate value 192,008026123047, OK
Bass 2.4.14.14 returns BitRate value 442750528913408, not OK
BASS_ErrorGetCode returns 37;  // Requested data is not available.

Looks like something has changed since 2.4.14.0.


Best regards,

John
« Last Edit: 10 Jul '19 - 14:20 by John F »

Ian @ un4seen

  • Administrator
  • Posts: 22253
Re: BASS_ChannelGetAttribute
« Reply #1 on: 10 Jul '19 - 16:39 »
If you call BASS_ChannelGetinfo on the stream, what "ctype" value do you see?

Please also confirm what platform you are using BASS on and upload an affected file to have a look at here:

   ftp.un4seen.com/incoming/

John F

  • Posts: 3
Re: BASS_ChannelGetAttribute
« Reply #2 on: 11 Jul '19 - 07:43 »
ctype value is 65541, BASS_CTYPE_STREAM_MP3
Platform is Windows, Delphi.

I get the error with multiple files, I've uploaded one mp3 file.

Ian @ un4seen

  • Administrator
  • Posts: 22253
Re: BASS_ChannelGetAttribute
« Reply #3 on: 11 Jul '19 - 12:03 »
Ah yes, I see the problem now. It's a bug that was introduced in a recent update. Here's another update to correct that:

   www.un4seen.com/stuff/bass.zip

John F

  • Posts: 3
Re: BASS_ChannelGetAttribute
« Reply #4 on: 11 Jul '19 - 16:16 »
Yep, is fixed.

Thanks