Author Topic: Font in skins  (Read 8982 times)

Akic

  • Guest
Font in skins
« on: 10 Aug '04 - 05:34 »
sorry for my poor English.
i downloaded some skins form support.xmplay.com.
but when i load them,there's a window called "Font warning" saying i didn't have the font installed.
if i use this skin,the warning appears everytime when i open xmplay.
i change the font in the skin source file,and everything seems to be ok.but i dunno how to make it to *.xmpskin file. it is too large.

Keltic Danor

  • XMPlay Support
  • Posts: 747
Re:Font in skins
« Reply #1 on: 10 Aug '04 - 05:38 »
Which .xmpskin is it that has the missing font?
and what is the font that is missing?

Once I get that info I'll upload a fixed one for you. :)
« Last Edit: 10 Aug '04 - 05:39 by Keltic Danor »

Akic

  • Guest
Re:Font in skins
« Reply #2 on: 10 Aug '04 - 05:56 »
the skins are:exile,byte and silk
missing font are:profont.fon,xmp_iso.ttf,agency.ttf
i fonud the missing fonts in the skin source ,and i copy them to my font folder.the problem is solved.but do i have to do this every time?

Keltic Danor

  • XMPlay Support
  • Posts: 747
Re:Font in skins
« Reply #3 on: 10 Aug '04 - 06:07 »
No you should'nt have to install the fonts at all. The xmpskin file includes all the fonts, so there should be no need for you to install them manually.
Not quite sure what is going on, so no quick and easy fix for this one yet. ???

Ian might have a clue whats happening.
* Keltic Danor waits for a sign from above. :P
« Last Edit: 10 Aug '04 - 06:08 by Keltic Danor »

Akic

  • Guest
Re:Font in skins
« Reply #4 on: 10 Aug '04 - 06:11 »
thank u all the same ;)

Ian @ un4seen

  • Administrator
  • Posts: 20389
Re:Font in skins
« Reply #5 on: 10 Aug '04 - 11:32 »
Please try redownloading the latest update, and see if it helps. If it doesn't help, what Windows version do you have, and where (path) do you have it installed? Also, what's your Windows username?

Akic

  • Posts: 23
Re:Font in skins
« Reply #6 on: 10 Aug '04 - 14:52 »
Please try redownloading the latest update, and see if it helps. If it doesn't help, what Windows version do you have, and where (path) do you have it installed? Also, what's your Windows username?
I'm using the newest version.
my os is windows xp home,and i installed xmplay in d:\software\xmplay.
BUT my username isn't alphabeta. i,m a chinese,so i use chinese. Does it matter?

helpermonkey

  • Guest
Re:Font in skins
« Reply #7 on: 10 Aug '04 - 15:47 »
I think I know what happened here.
Akic went to support.xmplay.com and grabbed the source files.
He decompressed them and put them into his/her XMPlay folder.
The skin of course works, but opens with a message that the font could not be found.
Once Akic put the font into his/her fonts folder, everything works fine.

You can notice that when you see Akic asking for how to make an .xmpskin file.
Akic, you can't make an .xmpskin file. It's the compiled result of the source files you grabbed. Grab the .xmpskin file instead and put this one in your XMPlay skin folder. It contains the skins and will load them with no probs.

Akic

  • Posts: 23
Re:Font in skins
« Reply #8 on: 10 Aug '04 - 15:58 »
I think I know what happened here.
Akic went to support.xmplay.com and grabbed the source files.
He decompressed them and put them into his/her XMPlay folder.
The skin of course works, but opens with a message that the font could not be found.
Once Akic put the font into his/her fonts folder, everything works fine.

You can notice that when you see Akic asking for how to make an .xmpskin file.
Akic, you can't make an .xmpskin file. It's the compiled result of the source files you grabbed. Grab the .xmpskin file instead and put this one in your XMPlay skin folder. It contains the skins and will load them with no probs.
NO! the warning appears when i use both the .xmpskin file and the source file.
i can only copy the font which is contained in the source file to my font folder to use the skin.

Ian @ un4seen

  • Administrator
  • Posts: 20389
Re:Font in skins
« Reply #9 on: 10 Aug '04 - 16:08 »
BUT my username isn't alphabeta. i,m a chinese,so i use chinese. Does it matter?

That's what the update should have sorted, so... did it? ;)

Akic

  • Posts: 23
Re:Font in skins
« Reply #10 on: 10 Aug '04 - 16:20 »
yep ;)
i like the software.
i was using stp before,but now it's dying...
thank U for such a great thing,and i hope xmplay 4.X or 5.X can be internationalization :)

Brian

  • Posts: 733
Re:Font in skins
« Reply #11 on: 14 Aug '04 - 18:21 »
I have the same problem with these two skins: PowerDee (Arial Narrow) and Shades (Small Fonts).

Keltic Danor

  • XMPlay Support
  • Posts: 747
Re:Font in skins
« Reply #12 on: 15 Aug '04 - 13:02 »
Arial Narrow is a font that comes with MS Office, otherwise its a commercial font. So it can't be included in the .xmpskin. :-X

Small Fonts comes default with all versions of Windows so you should have it already. But I've uploaded it here.  ;D

Brian

  • Posts: 733
Re:Font in skins
« Reply #13 on: 15 Aug '04 - 14:18 »
Thanks, that's helpful. For some reason I have neither of these fonts on my system.

Later note: I've been able to get hold of Arial Narrow as part of a package available for download from the Microsoft website.
« Last Edit: 15 Aug '04 - 15:02 by Brian »