Author Topic: XMPlay SID plugin  (Read 297736 times)

Diz_57

  • Posts: 13
Re: XMPlay SID plugin
« Reply #600 on: 12 Apr '18 - 07:53 »
Even with non-upx'ed dll I can confirm instant crash on every sid loaded on Win XP SP3  :'(

deus-ex

  • Posts: 244
Re: XMPlay SID plugin
« Reply #601 on: 12 Apr '18 - 09:53 »
You may wan't to try if the previous release works for you then, no guarantees though. It's already un-UPXed.

Diz_57

  • Posts: 13
Re: XMPlay SID plugin
« Reply #602 on: 12 Apr '18 - 19:05 »
Umm... yeah... thanks... rev 36 is what i was using before 37. 36 works fine but I was just confirming the issue with 37. ;)

wilk

  • Posts: 1
Re: XMPlay SID plugin
« Reply #603 on: 16 May '18 - 12:45 »
r37.1 crashes for me as well (XP SP3 32b), r36 works fine.

This error suggests that invalid opcode is executed (haven't disassebled however), which suggests that the latest version was compiled with SSE2 enabled (ancient hw here :>). Or at least some parts of it like player routines/libs, because xmplay starts fine and about + config dialogs for this plugin can be displayed, as well as xmplay does retrieve song information through this plugin [track info] and error pop-ups on play.
« Last Edit: 16 May '18 - 21:39 by wilk »