Author Topic: XMPlay Apple Lossless plugin  (Read 63842 times)

Pike84

  • Posts: 1398
Re: XMPlay Apple Lossless plugin
« Reply #25 on: 14 Apr '10 - 12:32 »
.

REVerdi

  • Posts: 21
Re: XMPlay Apple Lossless plugin
« Reply #26 on: 2 Apr '11 - 01:10 »
The problem reported below is happening with the latest version of the plugin (23 Mar '11).

When starting xmplay with the current alac plugin I get a message "The application has failed to start because MSVCRTD.dll was not found. Re-installing the  application may fix this problem". Xmplay then starts but unable to play alac files.

Ian @ un4seen

  • Administrator
  • Posts: 20396
Re: XMPlay Apple Lossless plugin
« Reply #27 on: 4 Apr '11 - 14:46 »
Oops, that's the debug run-time library. An update using the normal library version is up in the 1st post now.

bittin-

  • Guest
Re: XMPlay Apple Lossless plugin
« Reply #28 on: 9 Apr '13 - 13:22 »
Thanks just bought some ALAC files and found this old plugin it works great :)

galleyrod

  • Posts: 10
Re: XMPlay Apple Lossless plugin
« Reply #29 on: 11 Aug '14 - 13:38 »
Is there a version of this plugin that supports TAGs?? I have an album in *.m4a format and although the TAG information is present in the files it is not supported by the plugin.

Regards,

Ian @ un4seen

  • Administrator
  • Posts: 20396
Re: XMPlay Apple Lossless plugin
« Reply #30 on: 11 Aug '14 - 14:17 »
The current ALAC plugin should already support tags. If it's apparently not seeing the tags in a particular file, please upload the file to have a look at here...

   ftp.un4seen.com/incoming/

galleyrod

  • Posts: 10
Re: XMPlay Apple Lossless plugin
« Reply #31 on: 12 Aug '14 - 15:11 »
done.

Ian @ un4seen

  • Administrator
  • Posts: 20396
Re: XMPlay Apple Lossless plugin
« Reply #32 on: 12 Aug '14 - 15:51 »
Thanks. I see the uploaded file has an extra atom that the ALAC add-on wasn't expecting, resulting in it not finding the tags that follow. Here's an update that should fix the problem...

   www.un4seen.com/stuff/xmp-alac.dll

galleyrod

  • Posts: 10
Re: XMPlay Apple Lossless plugin
« Reply #33 on: 12 Aug '14 - 17:22 »
works like a charm  8)

Ian @ un4seen

  • Administrator
  • Posts: 20396
Re: XMPlay Apple Lossless plugin
« Reply #34 on: 13 Aug '14 - 17:09 »
Great. The update (rev.4a) is up on the XMPlay page now.

galleyrod

  • Posts: 10
Re: XMPlay Apple Lossless plugin
« Reply #35 on: 14 Aug '14 - 13:24 »
Ian, I maybe wrong, but the track information from file is not loading. The file I've sent you before had this information inside. Will you look into it?

Ian @ un4seen

  • Administrator
  • Posts: 20396
Re: XMPlay Apple Lossless plugin
« Reply #36 on: 14 Aug '14 - 15:16 »
Do you mean the tags aren't found by the ALAC plugin update posted on the XMPlay page, but the update posted above did find them? If so, that shouldn't be possible as they are the same DLL. Perhaps you have received a cached copy of the old version? What version number do you see in XMPlay's input plugins list? It should be "rev.4a". If it isn't that, you could try clearing your browser cache and then downloading again.

galleyrod

  • Posts: 10
Re: XMPlay Apple Lossless plugin
« Reply #37 on: 15 Aug '14 - 13:27 »
What I meant was that the field with track number in the album is missing but still present in the file. Plugin version 4a :)

Ian @ un4seen

  • Administrator
  • Posts: 20396
Re: XMPlay Apple Lossless plugin
« Reply #38 on: 15 Aug '14 - 17:09 »
Ah, I see what you mean now. The track number is visible in the "Message" info window, but not in the "Track info" window or library. Another update (rev.4b) that should fix that is now up on the XMPlay page. Let me know if it still has trouble with any of your files.