Author Topic: XMPlay Last.fm/Audioscrobbler plugin (xmp-scrobbler)  (Read 539731 times)

Jace

  • Posts: 825
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #75 on: 8 May '06 - 04:31 »
Does it still require the album tag too?

raina

  • Posts: 1163
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #76 on: 8 May '06 - 06:48 »
It'll say that if the Album tag is missing.

lingenfr

  • Posts: 59
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #77 on: 8 May '06 - 12:05 »
Seems that everytime last.fm goes offline (which is frequently lately) I get this error and according to previous instructions have to delete my cache. Darn.


2006-05-07 21:59:45   Could not connect to server.
2006-05-07 21:59:45   couldn't connect to host
2006-05-07 21:59:45   Unable to handshake: sleeping...
2006-05-07 22:01:17   XMP_GetChannelData (id = 67110017, ch = info1, hconv = 100666753, hdata = 134222593, hszService = 49153, hszTopic = 49155)
2006-05-07 22:01:17   Submitting track: Seal - Get It Together (Seal IV)...
2006-05-07 22:01:46   Unable to handshake: sleeping...
2006-05-07 22:03:13   xmptd.rate = 0
2006-05-07 22:03:13   xmptd.chans = 0
2006-05-07 22:03:13   DSP_StopTrack
2006-05-07 22:03:14   DSP_NewTrack (CLOSE)
2006-05-07 22:03:15   DSP_Free()
2006-05-07 22:32:09   DSP_New()
2006-05-08 06:55:43   DSP_NewTrack (OPEN)
2006-05-08 06:55:43   Found entries in cache: 22.
2006-05-08 06:55:43   ...
2006-05-08 06:55:43   xmptd.rate = 44100
2006-05-08 06:55:43   xmptd.chans = 2
2006-05-08 06:55:43   Next submission in 119 seconds...
2006-05-08 06:55:47   Handshaking: Client up to date.
2006-05-08 06:55:47   Submit interval set to 1 second(s).
2006-05-08 06:55:47   Handshake successful.
2006-05-08 06:57:40   XMP_GetChannelData (id = 33555585, ch = info1, hconv = 67112321, hdata = 100668161, hszService = 49153, hszTopic = 49154)
2006-05-08 06:57:40   Submitting track: Seal - Get It Together (Seal IV)...
2006-05-08 06:57:40   Submitting cache...
2006-05-08 06:57:40   ...
2006-05-08 06:57:44   The server reported a processing error.
2006-05-08 06:57:44   HTTP/1.1 100 Continue


2006-05-08 06:57:44   Submission failed: Plugin bug: Not all request variables are set
2006-05-08 06:57:44   Submit interval set to 1 second(s).
2006-05-08 06:59:42   DSP_NewTrack (CLOSE)
2006-05-08 06:59:42   DSP_NewTrack (OPEN)
2006-05-08 06:59:42   Next submission in 116 seconds...
2006-05-08 07:01:37   XMP_GetChannelData (id = 134219906, ch = info1, hconv = 167777666, hdata = 201330434, hszService = 49153, hszTopic = 49154)
2006-05-08 07:01:37   Submitting track: Seal - Let Me Roll (Seal IV)...
2006-05-08 07:01:37   Submitting cache...
2006-05-08 07:01:37   ...
2006-05-08 07:01:40   The server reported a processing error.
2006-05-08 07:01:40   HTTP/1.1 100 Continue


2006-05-08 07:01:41   Submission failed: Plugin bug: Not all request variables are set
2006-05-08 07:01:41   Submit interval set to 1 second(s).
2006-05-08 07:03:04   xmptd.rate = 0
2006-05-08 07:03:04   xmptd.chans = 0
2006-05-08 07:03:04   DSP_StopTrack
2006-05-08 07:03:05   DSP_NewTrack (CLOSE)
2006-05-08 07:03:06   DSP_Free()

Zarggg

  • Posts: 1242
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #78 on: 9 May '06 - 01:32 »
Yep. I've hit that error, as well.

sfsfs

  • Guest
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #79 on: 14 May '06 - 11:41 »
« Last Edit: 15 May '06 - 14:56 by Ian @ un4seen »

lingenfr

  • Posts: 59
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #80 on: 14 May '06 - 12:11 »
Yeah, what he said.

Alexsource

  • Posts: 258
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #81 on: 14 May '06 - 14:27 »
 ??? a chinese spambot? someone delete that :P

Tsorovan

  • Posts: 1247
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #82 on: 14 May '06 - 20:50 »
I think it's quite endearing.

Zarggg

  • Posts: 1242
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #83 on: 15 May '06 - 01:34 »
It's forumspam.

jammer

  • Guest
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #84 on: 15 May '06 - 13:48 »
one more, xmscrobbler often disappears from the list of selected dsp plugins. right now, i've just gone into the options and seen it deselected. :/

amit

  • Guest
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #85 on: 20 May '06 - 00:12 »
Hi , I am still waiting for the proxy support for this plugin. i hope you haven't forgot about it ;)

Amit.

lingenfr

  • Posts: 59
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #86 on: 20 May '06 - 00:49 »
yagood has been kinda quiet this month. Hope that a new version is coming out soon.

Zarggg

  • Posts: 1242
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #87 on: 20 May '06 - 02:11 »
Does anyone else get "bad authorization" errors CONSTANTLY?

Dotpitch

  • Posts: 2871
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #88 on: 20 May '06 - 09:53 »
one more, xmscrobbler often disappears from the list of selected dsp plugins. right now, i've just gone into the options and seen it deselected. :/
Plugins don't unload by themselves, at least, they shouldn't :P. Do you have Saved settings that automatically load? They apply to DSP-plugins too ;).

lingenfr

  • Posts: 59
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #89 on: 20 May '06 - 14:47 »


Ian,

Please boot this spambot.
« Last Edit: 20 May '06 - 15:43 by Ian @ un4seen »

Ian @ un4seen

  • Administrator
  • Posts: 20389
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #90 on: 20 May '06 - 15:44 »
I think it could just be a bored human, rather than a bot, as I've not seen any other spam since the "Captcha" thing was added.

lingenfr

  • Posts: 59
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #91 on: 20 May '06 - 16:43 »
OK.

-- Spammers, ya can't live with 'em, ya can't hunt 'em down and smash their testes with a tent stake mallet (you know, like the circus workers use)

raina

  • Posts: 1163
WMA tags
« Reply #92 on: 24 May '06 - 17:35 »
Some WMA files aren't being sent to Last.fm here and my guess is that's because they use tags Author and WM/AlbumTitle instead of the tags Artist and Album. Could something be done about this?

yagood

  • Posts: 215
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #93 on: 27 May '06 - 00:35 »
That was a busy, busy month for me :o New version is out, check out first page. Let me know if I forgot about any request (except "excluded folders" feature - I still remember about it - it'll be included in the next version).

Zarggg

  • Posts: 1242
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #94 on: 27 May '06 - 02:15 »
Does anyone else get "bad authorization" errors CONSTANTLY?

So, I'm the only one with this problem? How do I solve it?

lingenfr

  • Posts: 59
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #95 on: 27 May '06 - 03:49 »
It still does not report Digitally Imported Radio, Shoutcast or Icecast. I am assuming it does not report any streaming except last.fm. Everything else seems to work. Hopefully this will take care of the crashing.

yagood

  • Posts: 215
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #96 on: 27 May '06 - 09:48 »
Does anyone else get "bad authorization" errors CONSTANTLY?

So, I'm the only one with this problem? How do I solve it?

Hmm... this is weird. Are you sure that you have proper username/password set in xmp-scrobbler configuration window? Could you paste log file contents with the error here?

It still does not report Digitally Imported Radio, Shoutcast or Icecast. I am assuming it does not report any streaming except last.fm.

No, it doesn't. And I'm not sure if I should support this as it's not recommended in the Audioscrobbler protocol specification:

"If a user is playing a stream instead of a regular file, do not submit that stream/song."

And that's what Winamp plugin is doing - it doesn't submit anything except regular music files. What are your thoughts about this?

Everything else seems to work. Hopefully this will take care of the crashing.

Well, actually, I can't guarantee that crashing problem is gone. It happens from time to time on my machine and it's extremely annoying, I know. That's why I've put more debugging info into the log file. If the crash happens for you - just paste last log file contents in this thread or send it to me.

lingenfr

  • Posts: 59
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #97 on: 27 May '06 - 14:10 »
IANAP, but it would seem to me that if those stations can display the artist and title in XMPlay, that could be submitted to last.fm, but I did read the spec. My thought is that if we wanted to follow the rules we would be using Windows Media Player. Maybe thats just me.

I have been uploading my DrWatson info, is that doing any good or should I stop? What logs should I send/post when it crashes and to where?

yagood

  • Posts: 215
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #98 on: 27 May '06 - 14:26 »
IANAP, but it would seem to me that if those stations can display the artist and title in XMPlay, that could be submitted to last.fm, but I did read the spec. My thought is that if we wanted to follow the rules we would be using Windows Media Player. Maybe thats just me.

Of course it can be submitted if XMPlay fills artist and title fields properly. I'm only saying that streams shouldn't be submitted according to the specification. I'll have to think about that if it makes any sense to implement support for streams...

I have been uploading my DrWatson info, is that doing any good or should I stop? What logs should I send/post when it crashes and to where?

Did you have a crash with the new version? I've been listening to music for a couple of hours today and no crash so far for me. But that of course doesn't mean that bug is fixed. So check if you have xmp-scrobbler.txt file in your XMPlay directory. If not, that would be weird (and also a bug). If yes, just paste a few last lines from it so that I could figure out at which point it crashed. Oh, and DrWatson info is useful too.  If you would want to send it by e-mail, send it here: yagood@o2.pl. TIA.

lingenfr

  • Posts: 59
Re: XMPlay Audioscrobbler plugin (xmp-scrobbler)
« Reply #99 on: 27 May '06 - 15:23 »
No, the new version has not crashed. It seems to be doing a lot of 'track to short stuff' on tracks that are not too short and then just dieing. To be clear, I start a playlist of properly tagged ogg files, all of which are more than 30 seconds. The log says the first track is too short and then nothing. It looks like the plug-in dies and never tries to submit again. Here is my log that shows a couple of attempts.

2006-05-27 09:46:57   [DEBUG] xmptd.rate = 0
2006-05-27 09:46:57   [DEBUG] xmptd.chans = 0
2006-05-27 09:46:57   [DEBUG] DSP_StopTrack
2006-05-27 09:46:59   [DEBUG] DSP_Free()
2006-05-27 09:47:03   [DEBUG] DSP_New()
2006-05-27 09:47:15   [DEBUG] xmptd.rate = 44100
2006-05-27 09:47:15   [DEBUG] xmptd.chans = 2
2006-05-27 09:47:15   XMP_SetTimer( 0 )
2006-05-27 09:47:15   Track is too short to submit it (must be at least 30 seconds long).
2006-05-27 09:56:43   [DEBUG] xmptd.rate = 0
2006-05-27 09:56:43   [DEBUG] xmptd.chans = 0
2006-05-27 09:56:43   [DEBUG] DSP_StopTrack
2006-05-27 09:56:44   [DEBUG] DSP_Free()
2006-05-27 09:56:50   [DEBUG] DSP_New()
2006-05-27 09:56:50   [DEBUG] xmptd.rate = 44100
2006-05-27 09:56:50   [DEBUG] xmptd.chans = 2
2006-05-27 09:56:50   XMP_SetTimer( 0 )
2006-05-27 09:56:50   Track is too short to submit it (must be at least 30 seconds long).

In between the "Track is too short" messages, I closed and reopened XMP. No difference. I rolled back to the previous version and it worked fine with the same files. I rolled forward again and got the same thing. Immediately upon launching the file, one "Track is too short" and then nothing. Let me know what I can do to help. I have time to do more testing.