Author Topic: Old:Winamp Visualisations in XMPlay (0.9.11) (plus album art with auto download)  (Read 126135 times)

Barna

  • Posts: 105
You can do either:
TAG.EXE --recursive --removeid3v2 *.flac
To just remove all id3v2 from all flac files in one directory and all subdirectories, or
TAG.EXE --recursive --remove --force FLAC *.flac
to remove all types of tags except FLAC-tags from your files.

At least the sample file you sent me also has an ID3v1 tag (which is stored at the end of the file unlike the others), so maybe you want to go with the second one. But, just as in the linked hydrogenaudio forum thread, it is suggested, to test it first with some sample copies of your files in another directory before applying it to a big collection.

dypsis

  • Posts: 85
Thanks Barna. I have learnt a bit about tags.

What is a good way to identify what tags a file has?

Mp3tag did not detect that I still had ID3v1 tags.

Barna

  • Posts: 105
XMPlay actually is :-)
Check the message window (F2) and it outputs all tag sections in the file.

Otherwise you can also use that tag program. Just start it without a remove-command, but with --hidetags. i.e.:
TAG.EXE --hidetags <files>
TAG.EXE --hidetags *.flac
TAG.EXE --hidetags --recursive *.flac
TAG.EXE --hidetags --recursive *.*

Just check the third outputted line of each file (Tags:)
You can also add --tofilen <SOMEFILENAME>.TXT to save the output into a text file.

dypsis

  • Posts: 85
Thanks Barna.  :)

Actually, I found that the command was simply tag.

tag *.flac

or

tag filename.flac
« Last Edit: 11 Jun '08 - 20:04 by dypsis »

jairmoreno

  • Posts: 9
Thank you for your great work... It works almost perfect =D

Dimon3000

  • Posts: 9
I added a fifth align/stretch option which disables all stretching and aligning completely.
It would be nice if you also add an option which disables all stretching and aligns cover at center.

dypsis

  • Posts: 85
When I switch between message and visuals when playing FLAC files, XMPlay sometimes crashes.

This happens when playing FLAC files with FLAC only tags.

Is anyone else experiencing this with FLAC files?

Barna

  • Posts: 105
hmm, I can't reproduce it with the two FLAC files I have. I tried to switch from F2 (message) to F4 (visuals) or by just holding the F4 key (which switches the visuals on and off pretty fast). It didn't crash for me. I also tried it with both winamp plugins enabled and no plugin.
I'm using XMPlay 3.4.2.49 and FLAC rev. 6.

Are you using a Winamp visualisation plugin or do you just use the cover feature? If yes, which one?

It would be nice if you also add an option which disables all stretching and aligns cover at center.
Dimon3000, please (re-)download 0.9.9, I changed the new option to always center instead of top left corner.

dypsis

  • Posts: 85
Are you using a Winamp visualisation plugin or do you just use the cover feature? If yes, which one?
I am just using the cover feature.

Y@nekŪ

  • Posts: 273
Please add default album art loader from plugins folder (plugins/cover.jpg) option if no album detected.

Dimon3000

  • Posts: 9
Dimon3000, please (re-)download 0.9.9
Exactly what i needed! Thank you!

rofrol

  • Posts: 6
Hello there,
1st: I discovered xmplay a view days before and I am enthusiastic about it! It's small, it starts super-fast, and step by step I get all the stuff I liked so much with winamp. But I can't solve one Problem and that's album-art:  when I right click in the visuals window and chosse winamp wrapper 0.9.9, I can open (like described) a menue with the middle bottom of my mouse. When I choose "show album art" (by the way, the only black item, the rest ist grey) the plugin generates a file called vis.ini (content: [winamp_svp] show_albumart=1).
That's all. There's no album art (like in winamp), and I can't do this procedure again, until I delete the vis.ini. Did I miss to install another plugin?
Thx 4 your HELP!
rofrol

Dotpitch

  • Posts: 2871
Tick 'Show album art', then the plugin will load album art from the current file or from the folder that file is located in (like album.jpg, front.jpg, etc.). If you middle-click again and go to 'Auto cover download', you can have the plugin automatically search and download covers from Amazon sites (ofcourse you need an internet connection).

rofrol

  • Posts: 6
That's exactly what I do ... but when I choose "show album art" the plugin generates a file called vis.ini. Really: that's all. There's no jpg displayed and I can't right click in "visuals" any more until I delete vis.ini.

Dotpitch

  • Posts: 2871
That's nasty... So when you tick that, you can't change visuals anymore, not even with your scroll wheel? Does the window show 'No album art'? What XMPlay version are you on? (Get the latest 'stuff' build here.)

rofrol

  • Posts: 6
That's wright (and nasty). I even can't see one jpg (and I can't scroll). I've the latest version of xmplay, the latest version of the pugin (winamp Wrapper 0.9.9). It's shown in the 'Visual' window. I've deinstalled winamp. Is this necessary?
When I press middle mouse buttom for options (after I deleted vis.ini), there are only two options: 'Show album art' and 'Load Plugin'. The other options are grey.

rofrol

  • Posts: 6
I attach a screenshot ...
« Last Edit: 7 Jul '08 - 21:22 by rofrol »

rofrol

  • Posts: 6
Ooops - too big. Here's a smaller one ...

rofrol

  • Posts: 6
STOP! Sorry, that wasn't the latest xmplay version. With the one from your link, everything works great!
Thank you so much!

Barna

  • Posts: 105
Thanks for the report rofrol.
Of course it shouldn't crash like it did. So I added a few checks into 0.9.9 and also a message box informing the user that the cover feature requires a newer version.

Please add default album art loader from plugins folder (plugins/cover.jpg) option if no album detected.
It's also included now (and still 0.9.9, I'm scared of 1.0). It loads cover.jpg (or cover.png) if available from the same directory where the winamp_svp.svp is stored. It does the same with a file named download.jpg (or download.png) to replace the 'Downloading...' image which is shown while the auto downloader is active.
http://www.nukular.ch/winamp_svp_0.9.9.zip

Zarggg

  • Posts: 1242
(and still 0.9.9, I'm scared of 1.0)
What's wrong with 0.9.10? (or .11 as the case may actually be)

Y@nekŪ

  • Posts: 273
Quote from: Y@nekŪ link=topic=8128.msg59420#msg59420
It's also included now
[/quote

You are genius! Thank you!

dypsis

  • Posts: 85
I am sorry to gave to report this, but XMPlay is still crashing when viewing album art with FLAC files.  :-[

I am using 3.4.2.56.

Barna

  • Posts: 105
Again I still can't reproduce this crash with your FLAC file and my own test file. I clicked around and switched songs and let them play through and stuff and then I tried again by holding F4 and switching songs. Didn't get one crash.
I don't know if you can give more detailed info on the crash or if it just happens randomly for you after a while of music listening.

dypsis

  • Posts: 85
Hi Barna.
Thanks for your reply.

I don't know what to say. But this is happening on more than 1 computer.
I wonder how many users are using this with FLAC.

By the way. No problems with MP3.