Author Topic: silent midi  (Read 6261 times)

Sam_Zen

  • Posts: 113
silent midi
« on: 3 Aug '08 - 02:11 »
I used XMPlay as default player on my W2K set, which broke down.
So now I'm transferring all my apps on a new machine with XP SP1.
So I set up XMPlay again, including the proper plugins, like the one for MIDI.

But playing *.mid files so far didn't succeed. It's loadedd, the time-slider runs, but no sound.
I tried several things in the output option, but no luck.
Other apps play the mid-file correct, so this is not a system error.

To complete the info : I have asio4all installed.

Jace

  • Posts: 825
Re: silent midi
« Reply #1 on: 3 Aug '08 - 08:13 »
Do you have any midi soundbanks loaded?

Options & Stuff -> Plugins -> MIDI -> Config

saga

  • Posts: 2179
Re: silent midi
« Reply #2 on: 3 Aug '08 - 11:31 »
(hint: there's a link to a free soundfont on the xmplay information site, and there's also a thread about good midi soundfonts i started a while ago)

Sam_Zen

  • Posts: 113
Re: silent midi
« Reply #3 on: 4 Aug '08 - 04:30 »
I have some extended SF2 soundbanks in my archive, which I will maybe load in the future.
But being setting up the basic system again, I thought I could rely on the built-in soundbank of the on-board soundchip.
If I open .. MIDI -> Config, I just get : 'Soundfonts - Bank : 000'.
Another category of 128 files in that list started with d000, but it made no difference.
If I try 'add' in that dialog, XMplay scans for a sf2 file on the system, but can't find any.
Although a filename is auto-rendered in the dialog, that is obviously related to the onboardchip.

Edit : I solved the problem. The basic sf2 file couldn't be found, because in the 'add' dialog the wrong path was used.
It still used the path of my old W2K machine : c:\WINNT\system32\drivers\*.sf2,  instead of the XP-path, which is
c:\WINDOWS\system32\drivers\ again.
To be honest, I consider this a bit as a buggy behaviour.

Rah'Dick

  • XMPlay Support
  • Posts: 932
Re: silent midi
« Reply #4 on: 4 Aug '08 - 09:12 »
I'd rather call that behaviour "not as intelligent as it could be" (in terms of user-friendlyness). A bug is a technical error which can lead to logical misbehaviour or crashes.

Suggestion for Ian: add a file-exists-check to all soundfonts (of course only a single dialog notifying of all missing files at once) and a warning if no sound font is loaded. :)

Ian @ un4seen

  • Administrator
  • Posts: 20400
Re: silent midi
« Reply #5 on: 4 Aug '08 - 15:47 »
I have some extended SF2 soundbanks in my archive, which I will maybe load in the future.
But being setting up the basic system again, I thought I could rely on the built-in soundbank of the on-board soundchip.

The MIDI plugin doesn't use on-board soundbanks (the vast majority of soundcards don't even have on-board soundbanks). Instead, the plugin uses SF2 soundfonts to provide the sounds, and will default to using the Creative soundfont (ct4mgm/ct2mgm.sf2) if it is present, eg. installed with Creative/SoundBlaster drivers. What soundcard/drivers do you have installed?

Edit : I solved the problem. The basic sf2 file couldn't be found, because in the 'add' dialog the wrong path was used.
It still used the path of my old W2K machine : c:\WINNT\system32\drivers\*.sf2,  instead of the XP-path, which is
c:\WINDOWS\system32\drivers\ again.

What soundfont did you find in that directory? The MIDI plugin looks for the Creative soundfont in the system directory (what you've written minus the "drivers" bit).

Sam_Zen

  • Posts: 113
Re: silent midi
« Reply #6 on: 5 Aug '08 - 03:33 »
It's indeed, as you mentioned, the ct2mgm.sf2 one.

Ian @ un4seen

  • Administrator
  • Posts: 20400
Re: silent midi
« Reply #7 on: 5 Aug '08 - 13:33 »
And it was in the "c:\WINDOWS\system32\drivers\" directory, rather than "c:\WINDOWS\system32\"? If so, please tell which driver/version you have installed.

heftig

  • Posts: 85
Re: silent midi
« Reply #8 on: 5 Aug '08 - 23:39 »
BTW, I also have a CT8MGM.SF2 and a 28MBGM.SF2 (in System32 and SysWOW64, together with CT2MGM.SF2 and CT4MGM.SF2). I have an X-Fi. The 28MBGM.SF2 was the default Soundfont in the Bank Manager.

Sam_Zen

  • Posts: 113
Re: silent midi
« Reply #9 on: 6 Aug '08 - 04:49 »
2 Ian
Sorry, I must have made some mistake, can't find 'ct2mgm.sf2' on my system.
Now, the MIDI plugin makes use of the file '2gmgsmt.sf2' in the '..\drivers\' subdir.

Ian @ un4seen

  • Administrator
  • Posts: 20400
Re: silent midi
« Reply #10 on: 8 Aug '08 - 12:49 »
BTW, I also have a CT8MGM.SF2 and a 28MBGM.SF2 (in System32 and SysWOW64, together with CT2MGM.SF2 and CT4MGM.SF2). I have an X-Fi. The 28MBGM.SF2 was the default Soundfont in the Bank Manager.

Here's an update that will also look for those 2 extra soundfonts...

   www.un4seen.com/stuff/xmp-midi.dll

It'll look for one of the 4 soundfonts in order of size (largest first).

Sorry, I must have made some mistake, can't find 'ct2mgm.sf2' on my system.
Now, the MIDI plugin makes use of the file '2gmgsmt.sf2' in the '..\drivers\' subdir.

Did that soundfont come with your soundcard drivers, and if so, what soundcard/drivers is that?

Sam_Zen

  • Posts: 113
Re: silent midi
« Reply #11 on: 9 Aug '08 - 09:39 »
I guess so. In my previous situation I had to deal with PCI soundcards, now the motherboard has itīs own sound processor.
I will check this out.