Author Topic: Stream missing Meta Data (2.4 beta as well)?  (Read 1541 times)

CliffCawley

  • Posts: 20
Hi,

I've recently tried playing the following stream using BASS 2.3 (and even tried 2.4 beta).

http://ormgas.dracoirs.com:8000/ocRelay.ogg

It plays fine, however there doesn't appear to be any Meta Data updates.

I tried the same stream in XMPlay and the titles update immediately as they also do in Winamp.

I can't seem to get these to work at all, in any version of BASS, not in my own code, or the netradio example.

Why does it work in XMPlay, but not in BASS (I realise they're slightly different, but aren't they based on similar code?)

How would I get the meta data from this to update correctly in BASS?

Cliff :)


Ian @ un4seen

  • Administrator
  • Posts: 20389
Re: Stream missing Meta Data (2.4 beta as well)?
« Reply #1 on: 28 Mar '08 - 15:31 »
How are you detecting/processing the metadata updates? Note that BASS_TAG_META only applies to Shoutcast streams, and BASS_TAG_OGG should be used instead for Icecast/OGG streams.

The NETRADIO example only included Shoutcast streams, but I have now added Icecast/OGG support (in the C version); the update is in the 2.4 beta download :)

CliffCawley

  • Posts: 20
Re: Stream missing Meta Data (2.4 beta as well)?
« Reply #2 on: 29 Mar '08 - 08:17 »
Ahh, I was checking ICY then HTTP, not sure why I didn't end up checking the Ogg as well  ???

Thanks for clearing that up, it now works great (also works great in 2.4 beta) :D

Cliff :)