Author Topic: BASS for WinCE  (Read 217309 times)

SuperNoobwithNoobonTop

  • Guest
Re: BASS for WinCE
« Reply #50 on: 13 Apr '09 - 21:58 »
My I receive this bass.dll file as well.

Thanks


Fazlo

  • Guest
Re: BASS for WinCE
« Reply #51 on: 14 Apr '09 - 11:35 »
Hi,

Could I have the bass.dll for winCE file too...

fadl@eim.ae

Thanks...

SuperNoobwithNoobonTop

  • Guest
Re: BASS for WinCE
« Reply #52 on: 14 Apr '09 - 15:42 »
And I forgot my email address with my last request:
DocofEvil@gmail.com

auroralview

  • Guest
Re: BASS for WinCE
« Reply #53 on: 17 Apr '09 - 19:52 »
Can we use the "Bass.Misc.Waveform" class the BASS for Win-CE.
it is a good visualization ability but it is still not supported for BASS-CE. is it possible to adapt this class from BASS to BASS-CE?
i have checked the example program supplied by the Bass-CE package but it is written in C++.

Do you have a plan to release the new version of BASS-CE in these days ?
i am looking forward to checking it :)))
THanks...

radio42

  • Posts: 4480
Re: BASS for WinCE
« Reply #54 on: 17 Apr '09 - 22:01 »
As already written - it is a bit tricky to convert the WaveForm to CE, as it today uses various .Net methods which are simply not supported by the .Net CF v2.0.
So for today this would mean a total redesign - and I don't know if this is possible.
But as already said - I'll look into it...but this might take some time...not days...more weeks ;-)

SuperNoob

  • Guest
Re: BASS for WinCE
« Reply #55 on: 20 Apr '09 - 13:35 »
Getting the "System.NotSupportedException" when trying to record with this code:

Code: [Select]
       
public void Record()
        {
            myRecordProc = new RECORDPROC(MyRecording);
            stream = Bass.BASS_RecordStart(44100, 1,   // This call throws the error
                BASSFlag.BASS_RECORD_PAUSE, myRecordProc, IntPtr.Zero );

I am using the bass.dll sent to me as well as the 2.4.0.4 Bass.Net.compact.dll posted a week ago
Basically, I am trying to get this code http://nyxtom.vox.com/library/post/voice-chat-in-c.html working on windows mobile 6

Thanks,
Mike

radio42

  • Posts: 4480
Re: BASS for WinCE
« Reply #56 on: 20 Apr '09 - 16:18 »
Here comes the new BASS.NET CE version (for the .Net CompactFramework 2.0):
v2.4.0.5:
www.un4seen.com/filez/4/Bass24.Net_compact.zip

It should now fix the BASS_RecordStart issue.
Please note, that I needed to change the RECORDPROC signature for CE in order to work properly!
It is now defined as:
Code: [Select]
public delegate int RECORDPROC(int handle, IntPtr buffer, int length, IntPtr user)So you need to return either Bass.TRUE or Bass.FALSE instead of a bool value!

Let me know what you find...

rage2001

  • Posts: 1
Re: BASS for WinCE
« Reply #57 on: 20 Apr '09 - 23:25 »
Hia

I will use the bass.dll for WinCE with Freepascal for WinCE, can you send me the DLL?.
Thanks and sorry for my bad english.

cu rage

rage@geitei.de

houndeyex

  • Posts: 5
Re: BASS for WinCE
« Reply #58 on: 24 Apr '09 - 06:15 »
Hello,

I'd like to use the WinCE DLL with .NET on an HTC Fuze for MP3 streaming if I could get a copy of it please. I've registered for the BASS.NET beta and have my key ready.

I may be mistaken in thinking that you have to use the WinCE DLL and the .NET DLL in combination. Sorry if that's wrong, it's a little unclear from some of the other posts. All I need is functionality in .NET for Windows Mobile 5/6.

Thanks!
-James
houndeyex@gmail.com
« Last Edit: 24 Apr '09 - 06:19 by houndeyex »

houndeyex

  • Posts: 5
Re: BASS for WinCE
« Reply #59 on: 25 Apr '09 - 17:46 »
I'm having issues with BASS_StreamCreateURL. Mostly, I'm getting an error code 40 (Timeout Error). This happens both in my own applications and in netradio. I'm using C# and BASS.NET Compact with the WinCE BASS.dll.

Code: [Select]
    int mStream;
    string mURL = "[a valid, working url]";

    public frmMain()
    {
        InitializeComponent();
        BassNet.Registration("valid email", "my reg code");

        // init BASS using the default output device
        if (Bass.BASS_Init(-1, 44100, BASSInit.BASS_DEVICE_DEFAULT, IntPtr.Zero))
        {
            // create a stream channel from a file
            mStream = Bass.BASS_StreamCreateURL(mURL, 0, BASSFlag.BASS_DEFAULT, null, IntPtr.Zero);
            BASS_TAG_ID3 tag = new BASS_TAG_ID3();

            if (mStream != 0)
            {
                // play the stream channel
                Bass.BASS_ChannelPlay(mStream, false);
            }
            else
            {
                // error creating the stream
                BASSError error = Bass.BASS_ErrorGetCode();
                Console.WriteLine("Stream error: {0}", Bass.BASS_ErrorGetCode());
                MessageBox.Show("ERROR!\n" + error.ToString());
            }
        }
        else
        {
            MessageBox.Show("NO INIT");
        }
    }

Files off the local device are working great, but I have no luck with web streams. I've tried connections via ActiveSync, Wi-Fi, 3G... none of which are working on two different phones. Both phones are Windows Mobile 6 Professional on the AT&T network. Does anyone have any ideas about what is going on?

auroralview

  • Guest
Re: BASS for WinCE
« Reply #60 on: 25 Apr '09 - 18:21 »
hello,
please try using  BASSFlag.BASS_UNICODE flag with  calling BASS_StreamCreateURL method.
it should work with this flag, if you have the correct bass ce dll.

Using bass ce dll is a little bit different from the bass.net dll.
As the WinCE APIs exclusively use Unicode strings, all the streams in Bass CE are unicode and as far as i know bass ce doest not support floating point streams due to lacking of poor floating performance of winCE devices..

good luck
« Last Edit: 25 Apr '09 - 18:40 by auroralview »

houndeyex

  • Posts: 5
Re: BASS for WinCE
« Reply #61 on: 25 Apr '09 - 22:01 »
hello,
please try using  BASSFlag.BASS_UNICODE flag with  calling BASS_StreamCreateURL method.
it should work with this flag, if you have the correct bass ce dll.

Using bass ce dll is a little bit different from the bass.net dll.
As the WinCE APIs exclusively use Unicode strings, all the streams in Bass CE are unicode and as far as i know bass ce doest not support floating point streams due to lacking of poor floating performance of winCE devices..

good luck

I tried this on my device with no luck. However, after much struggle to get an internet connection on the Windows Mobile 6 Standard emulator I ran the program on it. It works fine on there, regardless of the UNICODE flag. Netradio works great on the emulator as well.

Any other ideas? I'm lost on this, and I'm hoping it's not my phone. Could something be blocking network access by the program on the phone? I've never had other troubles with network applications I've written.

One more thing... should I be calling the method with both DEFAULT and UNICODE flags, like this?

Code: [Select]
mStream = Bass.BASS_StreamCreateURL(mURL, 0, BASSFlag.BASS_DEFAULT | BASSFlag.BASS_UNICODE, null, IntPtr.Zero);
« Last Edit: 25 Apr '09 - 22:04 by houndeyex »

auroralview

  • Guest
Re: BASS for WinCE
« Reply #62 on: 26 Apr '09 - 18:30 »
Yes you should call the BASS_StreamCreateURL like what you have written. it has to be included BASS_Unicode flag.

With this flag if you have not manged to run the program, you must have a proxy configuration on your windows mobile device.
you have to configure it correctly or disable it. I have faced with the same problem and after just configuring my proxy settings correctly, it has worked fine on both my WM6 devices and emulator.

One another option is disabling the internet security and anti-virus programs temporarily.

But under normal conditions, with including BASS_UNICODE flag in your StreamCreateURL method and well configured proxy, the bassCE works fine.

« Last Edit: 26 Apr '09 - 20:02 by auroralview »

houndeyex

  • Posts: 5
Re: BASS for WinCE
« Reply #63 on: 27 Apr '09 - 07:33 »
Yes you should call the BASS_StreamCreateURL like what you have written. it has to be included BASS_Unicode flag.

With this flag if you have not manged to run the program, you must have a proxy configuration on your windows mobile device.
you have to configure it correctly or disable it. I have faced with the same problem and after just configuring my proxy settings correctly, it has worked fine on both my WM6 devices and emulator.

One another option is disabling the internet security and anti-virus programs temporarily.

But under normal conditions, with including BASS_UNICODE flag in your StreamCreateURL method and well configured proxy, the bassCE works fine.

I checked my device for any proxy settings and found none. Every Windows Mobile 6 device I've tried (besides the emulators) has had the same problem. On GPRS connections, netradio will actually sometimes say "HTTP/1.1 200 OK" and then throw the timeout error after that. Is there any way I can dig deeper into what is going on and find at what exact point it times out?

Any other suggestions for the traffic getting blocked? Any other settings I should look at?

houndeyex

  • Posts: 5
Re: BASS for WinCE
« Reply #64 on: 27 Apr '09 - 08:54 »
Yes you should call the BASS_StreamCreateURL like what you have written. it has to be included BASS_Unicode flag.

With this flag if you have not manged to run the program, you must have a proxy configuration on your windows mobile device.
you have to configure it correctly or disable it. I have faced with the same problem and after just configuring my proxy settings correctly, it has worked fine on both my WM6 devices and emulator.

One another option is disabling the internet security and anti-virus programs temporarily.

But under normal conditions, with including BASS_UNICODE flag in your StreamCreateURL method and well configured proxy, the bassCE works fine.

I checked my device for any proxy settings and found none. Every Windows Mobile 6 device I've tried (besides the emulators) has had the same problem. On GPRS connections, netradio will actually sometimes say "HTTP/1.1 200 OK" and then throw the timeout error after that. Is there any way I can dig deeper into what is going on and find at what exact point it times out?

Any other suggestions for the traffic getting blocked? Any other settings I should look at?

Okay, I actually just figured out the issue. Apparently AT&T puts a hidden proxy on their phones, which has to be disabled through some hacks. It affects WiFi connections and everything. There's some CAB files that will disable/restore this setting for you. What a pain. Thanks for pointing me in the right direction auroral.

http://forum.xda-developers.com/showpost.php?p=2441221&postcount=24

radio42

  • Posts: 4480
Re: BASS for WinCE
« Reply #65 on: 27 Apr '09 - 09:16 »
There is NO need for the UNICODE flag with BASS.NET - as BASS.NET adds that automatically anyhow internally ;-)
Beside that Win CE is internally ALWAYS unicode - as BASS.NET is.

auroralview

  • Guest
Re: BASS for WinCE
« Reply #66 on: 27 Apr '09 - 14:07 »
houndeyex, you are well come. as i said before, i have faced that problem many many times :))) If you can not connect the url, there may be a proxy server problem :)))

Dear radio42,

When i first receive the bass CE dll file from Ian, He has warned me about this BASS_UNICODE flag issue, so then i always include this flag whenever i call StreamCreateURL method in BASS CE.

but for the BASS.NET, i agree with you. there is no need to use this flag. it works ok without this flag:))
thanks...
« Last Edit: 27 Apr '09 - 14:22 by auroralview »

auroralview

  • Guest
Re: BASS for WinCE
« Reply #67 on: 27 Apr '09 - 14:09 »
By the way,

we are looking forward to seeing further improved and enhanced version of the lovely BASS_CE ;)

Thanks for everything.. :))

charmander

  • Posts: 3
Re: BASS for WinCE
« Reply #68 on: 29 Apr '09 - 02:51 »
Hi, i want bass.dll for trying to.

carreragt@windowslive.com

Thanks

fogologo

  • Posts: 2
Re: BASS for WinCE
« Reply #69 on: 4 May '09 - 17:53 »
hi
i would like to try the bass.dll for WinCe.

fogologo

  • Posts: 2
Re: BASS for WinCE
« Reply #70 on: 4 May '09 - 17:54 »
sorry forgot to write my email.... :-\
fogoland@inter.net.il

cloudraven

  • Guest
Re: BASS for WinCE
« Reply #71 on: 5 May '09 - 03:36 »
This looks pretty cool. I want to try it too!
eacuervo AT gmail

Thanks!

Ian @ un4seen

  • Administrator
  • Posts: 19489
Re: BASS for WinCE
« Reply #72 on: 5 May '09 - 17:16 »
The WinCE stuff is now available in the first post.

radio42

  • Posts: 4480
Re: BASS for WinCE
« Reply #73 on: 6 May '09 - 12:39 »
Here comes the new BASS.NET CE version (for the .Net CompactFramework 2.0):
v2.4.0.6:
www.un4seen.com/filez/4/Bass24.Net_compact.zip

It now also supports the BASSWV add-on as well as the WaveForm class.
However, WaveForm rendering seems to be quite slow  - at least on my Device Emulator it took over 1 minute to render a 5 minute MP3.
Let me know what you find...

charmander

  • Posts: 3
Re: BASS for WinCE
« Reply #74 on: 20 May '09 - 04:46 »
Hi,

I have a problem about Bass.BASS_ChannelSetPosition,

when i set the little time, like 95.242 second, it is working perfectly, but, when i change the position the larger value, like 5470,174 (second, not milisecond), it wont be start the correct place. after that, Bass.BASS_ChannelGetPosition is getting correct time, but, sound is not on the correct place. 

Thank you.