Author Topic: Raspbian Buster Playback problem  (Read 375 times)

rdkartono

  • Posts: 53
Raspbian Buster Playback problem
« on: 27 Aug '21 - 06:30 »
I have problem with playback on Raspbian Buster .
Using Raspbian Buster + Pi 3 or 4  + Onboard Audio + Bass --> Playback garbled and incorrect
Using Raspbian Buster + Pi 3 or 4  + USB soundcard + Bass --> playback correct

Previously Raspbian Jessie + Pi 3 , playback correct on both onboard audio and USB sound card .

Do somebody have same experience ? or maybe found a solution for this problem ?

From programming side, all 3 cases above, using the same codes and same Bass library.
Tried on latest BASS Linux ARM HardFP, still not solving problem .
 

Ian @ un4seen

  • Administrator
  • Posts: 23938
Re: Raspbian Buster Playback problem
« Reply #1 on: 27 Aug '21 - 17:46 »
Yes, that is a known issue with Raspbian Buster currently. The built-in headphones device/driver is reporting that there are 8 channels/speakers available, and BASS will initialize it to use all 8 by default, but that's resulting in garbled sound like you say. You can avoid that problem by using the BASS_DEVICE_STEREO flag in your BASS_Init call to limit the output to stereo. In future, BASS could perhaps try to detect the RPi headphones device and automatically limit the output to stereo then.

This issue should only affect using the headphones device directly. Using it via PulseAudio (eg. when you right-click the volume control and choose "AV Jack") shouldn't be affected because that reports a very high channel/speaker count, which BASS ignores by default (unless BASS_DEVICE_SPEAKERS is used). The built-in HDMI output is also unaffected (it can do 8 channel output without being garbled).

rdkartono

  • Posts: 53
Re: Raspbian Buster Playback problem
« Reply #2 on: 31 Aug '21 - 01:33 »
Confirmed !

BASS_DEVICE_STEREO fix the problem.
However, BASS_DEVICE_MONO don't fix it.

Ian @ un4seen

  • Administrator
  • Posts: 23938
Re: Raspbian Buster Playback problem
« Reply #3 on: 1 Sep '21 - 17:37 »
Indeed, the BASS_DEVICE_MONO flag doesn't currently affect the output on Linux, so it'll still be 8 channels/speakers by default in this case. I'll look into that for the next BASS update.

Btw, if you would like to confirm how many channels/speakers the BASS output is using, you can do so with BASS_GetInfo (see the "speakers" value).

Ian @ un4seen

  • Administrator
  • Posts: 23938
Re: Raspbian Buster Playback problem
« Reply #4 on: 8 Sep '21 - 14:59 »
A BASS update (2.4.16.7) that automatically limits the RPi headphones to stereo (and supports the BASS_DEVICE_MONO flag) is up now in the ARM Linux thread:

   www.un4seen.com/forum/?topic=13804