Author Topic: Midi SFZ font file filter opcodes not working on ARM Linux  (Read 69 times)

eschime

  • Posts: 6
I'm not noticing any difference when setting filter opcodes in sfz font files. I've tried fil_type, cutoff, and fil_veltrack at various settings and it doesn't seem to be working? Is this a limitation on linux or could there be a problem in the library?

Ian @ un4seen

  • Administrator
  • Posts: 23743
The filter opcodes should work on ARM Linux, but note that only the "fil_type=lpf_2p" setting is currently supported. Any higher pole lowpass settings (eg. "lpf_4p") will be treated as "lpf_2p", and any other setting (inc. "lpf_1p") will disable the filter. "lpf_2p" is the default, so you can just leave it at that.

If the filter is still apparently having no effect, is that even when the "cutoff" opcode is set very low? Please also confirm which of the ARM Linux versions you're using, ie. softfp/hardfp/aarch64.