Author Topic: .asf doesnt respect proxy setting  (Read 6736 times)

tongub

  • Posts: 91
.asf doesnt respect proxy setting
« on: 7 Apr '10 - 10:21 »
hi This problem has been there for a long time. i don't know that is happening. but many players that use system wma decoder have this problem.

the symptom is like this :

first we need a firewall or diagnostic tool like process explorer to find out which ip the player is trying to connect to. In process explorer, double click xmplayer.exe in the main window. select TCP/IP tab.

set a proxy in xmplayer and open a .asf stream url in xmplayer, e.g.  this link ,then switch back to TCP/IP tab immediately.

for the first few seconds xmplayer connect the proxy but later it switch back to the original url. I checked proxy by doing the same with WMP which seems the only player that supports proxy for .asf streams.

any idea if this can be fixed ? many websites are blocked in my country. ppl need proxy support. :) thanks.
« Last Edit: 19 Apr '10 - 06:52 by tongub »

Dotpitch

  • Posts: 2871
Re: .asf doesnt respect proxy setting
« Reply #1 on: 7 Apr '10 - 11:07 »
... xmplayer.exe ... xmplayer ... xmplayer ... xmplayer ...
XMPlay.
for the first few seconds xmplayer connect the proxy but later it switch back to the original url. I checked proxy by doing the same with WMP which seems the only player that supports proxy for .asf streams.
XMPlay starts up the stream by connecting to the server itself, so it finds out the stream is actually a WMA stream. The only way to receive the stream (that is, the only way without upsetting Microsoft) is to use the external Windows Media libraries that came with Windows. Apparently, those libraries don't receive the proxy information. Did you set WMP to follow your browser settings (IE), or did you configure it manually?

Ian @ un4seen

  • Administrator
  • Posts: 20437
Re: .asf doesnt respect proxy setting
« Reply #2 on: 7 Apr '10 - 14:55 »
Here's an update to try, which should use the XMPlay proxy settings for WMA streams too...

   www.un4seen.com/stuff/xmp-wma.dll

tongub

  • Posts: 91
Re: .asf doesnt respect proxy setting
« Reply #3 on: 9 Apr '10 - 15:39 »
Here's an update to try, which should use the XMPlay proxy settings for WMA streams too...

   www.un4seen.com/stuff/xmp-wma.dll

Thanx for the on-spot fix. It works now :) , though not in an expected way...
xmplay still tries to connect directly after connecting to the local proxy 2 times. the good thing is after the direct connection failed, it switches back to proxy.
i tried both WMP10 and xmplay. here is the comparison. :

/WMP10xmplay
settingproxy for all protocolproxy on
1st time connectionproxyproxy
2edproxy(buffering&playback)proxy
3rd--direct(time out due to blockage)
4th--proxy
5th--proxy(buffering&play)

there seems to be some kind of fallback? It would be great if this odd behavior is fixable.

... xmplayer.exe ... xmplayer ... xmplayer ... xmplayer ...
XMPlay.
er, sorry  ;D...

for the first few seconds xmplayer connect the proxy but later it switch back to the original url. I checked proxy by doing the same with WMP which seems the only player that supports proxy for .asf streams.
XMPlay starts up the stream by connecting to the server itself, so it finds out the stream is actually a WMA stream. The only way to receive the stream (that is, the only way without upsetting Microsoft) is to use the external Windows Media libraries that came with Windows. Apparently, those libraries don't receive the proxy information. Did you set WMP to follow your browser settings (IE), or did you configure it manually?
WMP is set to use proxy for all protocol. i also tried to set them to auto-detect proxy setting. hm. in my test, i fail to see any difference though.

« Last Edit: 14 Apr '10 - 18:34 by tongub »

Ian @ un4seen

  • Administrator
  • Posts: 20437
Re: .asf doesnt respect proxy setting
« Reply #4 on: 13 Apr '10 - 14:32 »
Can you give an example WMA stream URL that that happens with? The proxy settings only apply to HTTP connections, so my guess would be that the "direct" connection is an RTSP attempt and then it falls back to HTTP.

tongub

  • Posts: 91
Re: .asf doesnt respect proxy setting
« Reply #5 on: 14 Apr '10 - 18:30 »
Hi, the link in the op :-)
Quote
set a proxy in xmplayer and open a .asf stream url in xmplayer, e.g.  this link ,then switch back to TCP/IP tab immediately.
« Last Edit: 19 Apr '10 - 06:55 by tongub »

Ian @ un4seen

  • Administrator
  • Posts: 20437
Re: .asf doesnt respect proxy setting
« Reply #6 on: 15 Apr '10 - 16:14 »
OK, that example seems to be HTTP by default. Perhaps the direct connection is another plugin attempting to open the URL before the WMA plugin gets its turn then. Do you have any other plugins installed (maybe XMP-RA?), and if so, is there any difference after removing them?

tongub

  • Posts: 91
Re: .asf doesnt respect proxy setting
« Reply #7 on: 18 Apr '10 - 17:26 »
Ian thanks for the tip. indeed i have a lot plug-ins in the folder :-)
I found a duplicated WMA plug-in entry in my option window. um, i deleted all non binary files in xmplay folder and now it works fine.
hm. but the rm protocols doesn't seem to respect proxy though.

tongub

  • Posts: 91
Re: .asf doesnt respect proxy setting
« Reply #8 on: 19 Apr '10 - 06:08 »
oh. some correction. for real audio, xmplay connect twice through proxy and then fall back on direct connection. I tested with this link. As to "fall back", i can only see ip, not sure if it is trying the original link. :P
hope real-audio could be fixed too,(for this thread, maybe a bit off topic though)  thanks.

Dotpitch

  • Posts: 2871
Re: .asf doesnt respect proxy setting
« Reply #9 on: 19 Apr '10 - 08:44 »
for real audio, xmplay connect twice through proxy and then fall back on direct connection. I tested with this link. As to "fall back", i can only see ip, not sure if it is trying the original link.
XMPlay opens that link over HTTP and follows it to an RTSP stream. XMPlay handles the HTTP activities (using the proxy), but RTSP is handled by xmp-ra itself (apparently not using the proxy).

Fraggie

  • Posts: 710
Re: .asf doesnt respect proxy setting
« Reply #10 on: 19 Apr '10 - 20:40 »
I'll see what I can do...

tongub

  • Posts: 91
Re: .asf doesnt respect proxy setting
« Reply #11 on: 20 Apr '10 - 08:48 »
hi all. fixable or not, thanks for the attention. It's really appreciated.  :)

Fraggie

  • Posts: 710
Re: .asf doesnt respect proxy setting
« Reply #12 on: 30 Apr '10 - 17:40 »
I'm trying to set up a test environment for this. First, I want to see how it works with WMA. I have the latest greatest XMPlay and XMP-WMA from this thread, however I still can't see XMPlay connecting to mms:// through the proxy IP. Do I need some specific URL? Any idea?

Ian @ un4seen

  • Administrator
  • Posts: 20437
Re: .asf doesnt respect proxy setting
« Reply #13 on: 30 Apr '10 - 18:06 »
The XMPlay proxy settings only apply to HTTP connections, so you could try replacing the "mms://" bit with "http://" to force it to use HTTP.

I'll send you a code snippet for what XMP-WMA does with the proxy config.

Fraggie

  • Posts: 710
Re: .asf doesnt respect proxy setting
« Reply #14 on: 4 May '10 - 12:50 »
Here's something to try:
http://dhost.info/pieknyman/bin_data/test_version/xmp-ra.dll

Please check if playing over RTSP proxy works for a longer period of time (> 10 min). I've setup a local proxy server, but for some reason it fails to forward the heartbeat messages. I hope it'll be fine with "real world" conditions. The proxy support is supposed to work as described in XMPLAY docs.

tongub

  • Posts: 91
Re: .asf doesnt respect proxy setting
« Reply #15 on: 4 May '10 - 19:24 »
hi, thanks for replying  :)

i tried the new ra.all and got the same problem. it seems that "real" didn't open a http tunnel, before communication and talks rtsp directly with http proxy :(.

the guy in this thread mentioned " the RTSP-over-HTTP support in the "RTSPClient" class " which seems to be what we need. here comes another thread which makes the whole thing looks really complex.

it seems that a socks proxy is better. i only know vlc support socks and i have no idea, if ra plugin can support it or not (er, maybe socks support itself could be enough for another plug-in ?). but thank you for the efforts in improving proxy support. I can understand the difficulty, if ra proxy support is not possible. Plus wma support already make me quite happy. thanks for every dev's attention. :)
« Last Edit: 4 May '10 - 19:28 by tongub »

Fraggie

  • Posts: 710
Re: .asf doesnt respect proxy setting
« Reply #16 on: 5 May '10 - 13:07 »
Oh, so what you actually need is RTSP-over-HTTP tunneling and not proxy support for rtsp://.

Currently RTSP/RDT support for the plugin is really minimalistic and, frankly, is a one big hack. Adding RTSP cloaking would require quite a rewrite of the system. Maybe it's a good reason to clean all this stuff up. Once I feel brave enough, that is.  ;)