Author Topic: umlauts in OGG files' tags  (Read 2329 times)

Retro

  • Posts: 23
umlauts in OGG files' tags
« on: 26 Nov '02 - 19:37 »
Somehow umlauts get "converted" in Vorbis Ogg files' tags:

š ->  √?
Ų ->  √∂

Could it be Xmplay issue or OGG issue.
...or Windows issue :laugh:


Ralesk

  • Posts: 654
Re: umlauts in OGG files' tags
« Reply #1 on: 27 Nov '02 - 01:02 »
OGG tags support Unicode through the UTF-8 encoding.  This allows just about any character to be entered, even mixing different charsets, etc.

The display you see, √? and stuff, is because of that the tags are interpreted as ISO-8859-1 (Latin 1) character streams.

Seems that Ian needs to add Unicode support to the OGG tag viewer?

Ian @ un4seen

  • Administrator
  • Posts: 20433
Re: umlauts in OGG †files' tags
« Reply #2 on: 27 Nov '02 - 17:59 »
Please upload an example or two - ftp://ftp.un4seen.com/incoming - and I'll take a look at it.

There'll probably be a 2.5a released to fix little things like this. So if anyone has found any other little annoyances, now's the time to speak :)

Mik

  • Posts: 2
Re: umlauts in OGG †files' tags
« Reply #3 on: 28 Nov '02 - 16:31 »
Speaking of OGG tags, using the latest Nullsoft Vorbis Decoder plugin (1.2.9 I think), XMplay ignores the title display format settings specified by the plugin.  If a tag is present that contains the track title then only the track title is displayed regardless of the format settings specified.  Is that happening because XMplay is using its own ogg playback routines instead of the plugin?  If so, where can I change the internal ogg track display settings?  Thanks.