Author Topic: WASAPI non-exclusive mode  (Read 648 times)

Deb

  • Guest
WASAPI non-exclusive mode
« on: 23 Jul '16 - 20:03 »
Good day.

Can anyone please confirm that xmplay does not play sound in WASAPI non-exclusive mode? I am asking because if it does, then my PC is not configured correctly. Thank you for your attention.

Deb

  • Guest
Re: WASAPI non-exclusive mode
« Reply #1 on: 24 Jul '16 - 05:57 »
By WASAPI in non-exclusive mode I mean leaving the "Allow applications to take exclusive control of this device" box unchecked.

Dotpitch

  • Posts: 2871
Re: WASAPI non-exclusive mode
« Reply #2 on: 24 Jul '16 - 10:12 »
If Windows does not allow exclusive control of the device, XMPlay will play normally in non-exclusive mode, but it will give an error if you enable exclusive mode.

Deb

  • Guest
Re: WASAPI non-exclusive mode
« Reply #3 on: 24 Jul '16 - 10:35 »
Thank you for your reply.

My situation is the opposite of what you describe. If I choose WASAPI in the Output section of Options and Stuff in xmplay, I must check the "Allow applications to take exclusive control of this device". Otherwise, if the box is unchecked, I get the Output error "WASAPI driver doesn't support the output format." Any help will be appreciated. Thank you.

Dotpitch

  • Posts: 2871
Re: WASAPI non-exclusive mode
« Reply #4 on: 24 Jul '16 - 11:05 »
Go to the WASAPI sub-page in Options and stuff and disable exclusive mode.

Deb

  • Guest
Re: WASAPI non-exclusive mode
« Reply #5 on: 24 Jul '16 - 11:15 »
That did it! Thank you very much! Have a good one!