Author Topic: Wasapi "Exclusive mode" and Noises.  (Read 1154 times)

Asalfs

  • Posts: 5
Wasapi "Exclusive mode" and Noises.
« on: 17 Jul '16 - 18:48 »
1. Hi all. I am experiencing a issue related to "Exclusive mode" enabled option in Wasapi, which is: intermitent noises.
2. I did some research in forum, but I didn't find a clear solution, maybe due to my limited technical knowledge is this area.
3. When disabling the "Exclusive mode" in Wasapi tab, the XMPlay plays even the 24bits/192KHz resolution files without any noise. But I lost the benefits using the "exclusive mode", like auto set the resolution.
4. Configuration used: Windows 7 Home Premium 32bits (no updates) + Audioquest Dragonfly Usb Dac, first version.
 
Somebody knows about a solution or this is really a related issue? Thanks in advance.

Dotpitch

  • Posts: 2871
Re: Wasapi "Exclusive mode" and Noises.
« Reply #1 on: 17 Jul '16 - 19:03 »
Does the noise always appear at regular intervals? Does it depend on the output sample frequency?

Asalfs

  • Posts: 5
Re: Wasapi "Exclusive mode" and Noises.
« Reply #2 on: 17 Jul '16 - 19:18 »
No regular intervals. It's irregular and sometimes the player even crashes. It's independent on the output sample frequency also, but with higher resolutions, the noises seems to start faster.

Dotpitch

  • Posts: 2871
Re: Wasapi "Exclusive mode" and Noises.
« Reply #3 on: 18 Jul '16 - 19:49 »
What soundcard do you have?

Asalfs

  • Posts: 5
Re: Wasapi "Exclusive mode" and Noises.
« Reply #4 on: 20 Jul '16 - 03:37 »
No so sure. It's a integrated sound card (notebook HP dv2910us).
In Device Manager It just says: "Conexant High Definition SMartAudio 221"

Rittmeister

  • Posts: 9
Re: Wasapi "Exclusive mode" and Noises.
« Reply #5 on: 20 Jul '16 - 13:10 »
not trying to be an ass, but why do you even need Wasapi mode on a crappy ass notebook with 4gb ram and old core2duo no real gfx card...
The Bug probably is in your notebook hardware anyway.

Dotpitch

  • Posts: 2871
Re: Wasapi "Exclusive mode" and Noises.
« Reply #6 on: 20 Jul '16 - 18:58 »
What soundcard do you have?
Oh how sleepy of me...
... intermitent noises. ...  Audioquest Dragonfly Usb Dac, first version.
The Dragonfly seems to have caused problems for at least one other user. Still, if Windows can use it properly, XMPlay should be able to do it too :). Does plugging it into a different USB port or disabling wifi change anything on the noise?

saga

  • Posts: 2181
Re: Wasapi "Exclusive mode" and Noises.
« Reply #7 on: 21 Jul '16 - 01:06 »
Quote
Still, if Windows can use it properly, XMPlay should be able to do it too
Most applications don't use exclusive mode though, so it is entirely possible that it's actually broken in the driver.
Maybe it would be good to add another application to the game to check whether it's an XMPlay-specific issue. Sadly there are not too many audio applications that actually implement WASAPI exclusive mode, but you could get OpenMPT, go to the settings dialog, select a WASAPI device there and check "Use device exclusively". Do you get the same noise there as in XMPlay?

Asalfs

  • Posts: 5
Re: Wasapi "Exclusive mode" and Noises.
« Reply #8 on: 21 Jul '16 - 13:17 »
not trying to be an ass, but why do you even need Wasapi mode on a crappy ass notebook with 4gb ram and old core2duo no real gfx card...
The Bug probably is in your notebook hardware anyway.

 ;D I appreciate your honestly. But for my purpose It works pretty well, except for the sound. That's why I bought an external DAC.

The Dragonfly seems to have caused problems for at least one other user. Still, if Windows can use it properly, XMPlay should be able to do it too :). Does plugging it into a different USB port or disabling wifi change anything on the noise?

I happens with any USB port. I tried to disable wifi also. Using LatencyMoon I did some changes in Bios e power settings related to USB. But the problem only solves if "Exclusive Mode" is unchecked in Wasapi.

(...) but you could get OpenMPT, go to the settings dialog, select a WASAPI device there and check "Use device exclusively". Do you get the same noise there as in XMPlay?

I couldn't test this interesting tip right now because I don't have any midi file. But I'll search for some when get home.

saga

  • Posts: 2181
Re: Wasapi "Exclusive mode" and Noises.
« Reply #9 on: 21 Jul '16 - 22:01 »
OpenMPT is not a MIDI player. It comes with a few example modules (Help -> Example Modules) that you can try it with.

Asalfs

  • Posts: 5
Re: Wasapi "Exclusive mode" and Noises.
« Reply #10 on: 23 Jul '16 - 23:13 »
OpenMPT is not a MIDI player. It comes with a few example modules (Help -> Example Modules) that you can try it with.

Interesting. OpenMPT doesn't work when "Use device exclusively" is checked. It shows "Unable to open sound device". Maybe It's something related to the Windows7 driver.