Author Topic: Weird bug with Body Blows Galactic intro music  (Read 295 times)

AsmOne

  • Posts: 2
Hi, I found a weird sounding bug with Amiga's Body Blows Galactic intro music.
It sounds "wrong" at the beginning, before the drum part begins, then at 0:07 even the drum part is missing.
It's a standard .mod file, you can find it here
https://www.exotica.org.uk/wiki/Body_Blows_Galactic  (p4x.title)
BZRPlayer (http://bzrplayer.blazer.nu) makes it sound fine like on real hardware, so it can't be because of a  corrupt module.
XMPlay used is the latest (3.8.2.3).
For those who don't know or remember the game, here there's a Youtube video for the correct sounding mod
https://www.youtube.com/watch?v=v46iryT0UrQ

Thanks for reading :)

Ian @ un4seen

  • Administrator
  • Posts: 20437
Re: Weird bug with Body Blows Galactic intro music
« Reply #1 on: 6 Oct '17 - 17:41 »
That doesn't appear to be a standard MOD file, so I guess it must be a plugin that is handling the file. To find out which plugin, you can go to the "Plugins/Input" page in the options window when the file is open; the highlighted plugin in the list will be the one that is handling the file.

saga

  • Posts: 2183
Re: Weird bug with Body Blows Galactic intro music
« Reply #2 on: 6 Oct '17 - 19:46 »
It's a standard MOD file but is packed; The "MOD packer plugin" seems to handle the decompression and then passes it on to XMPlay's built-in MOD player. It's possibly a bug in the MOD packer plugin, since on first glance, only the lower 4 bits of instrument numbers in the pattern data are extracted. Note that you can find an uncompressed and working version of the soundtrack on ModLand: https://www.exotica.org.uk/mediawiki/index.php?title=Special%3AModland&md=search&mod=Body+Blows+2&aut=&for=&col=&ins=

AsmOne

  • Posts: 2
Re: Weird bug with Body Blows Galactic intro music
« Reply #3 on: 7 Oct '17 - 07:18 »
Thanks for your answers.
If can help for tracing the bug, the other player I mentioned before makes use of GPL'd Extended Module Player  .dll ( https://sourceforge.net/projects/xmp/ ), maybe it handles better obscure/exotic packers.

saga

  • Posts: 2183
Re: Weird bug with Body Blows Galactic intro music
« Reply #4 on: 7 Oct '17 - 13:31 »
You will need to ask Fraggie if he can fix the depacker, as he's the author of that plugin.