Author Topic: Issue with wavpack DSD files  (Read 1375 times)

garson

  • Posts: 161
Issue with wavpack DSD files
« on: 7 Dec '19 - 16:24 »
Hello Ian.

I compressed some DSD files using wavpack-5.1.0. But I have discovered issue with I believe XMPlay or wv plugin. After I add such file in xmplay it can't play, it just skips and goes to next track. Track has strikethrough line when it is skipped, like it doesn't exist on filesystem. Restart XMPlay and it is ok, no strikethrough line.
But after I restart XMPlay, it plays those files normally.  ???

But what is even more strange, once you add file and play it, issue with that file is gone. So just when you add a file for the first time, issue will happen. Delete file from playlist, try again, it will play normally.

XMplay is 3.8.3.30, wavpack rev. 6 and dsd rev.1 plugins.


« Last Edit: 7 Dec '19 - 16:44 by garson »

garson

  • Posts: 161
Re: Issue with wavpack DSD files
« Reply #1 on: 7 Dec '19 - 19:51 »
One more thing I noticed. When I add regular wavpack file into xmplay, duration is updated almost immediately. For wavpack dsd file it is not updated until I play the file (I just see -).

Ian @ un4seen

  • Administrator
  • Posts: 22396
Re: Issue with wavpack DSD files
« Reply #2 on: 9 Dec '19 - 17:54 »
I don't seem to be able to reproduce that here. Do you have the latest Wavpack and DSD plugins installed? If so, perhaps another plugin is interfering. Does the problem still happen if you remove all other input plugins? If that stops it, please try putting them back one at a time to find the culprit.

garson

  • Posts: 161
Re: Issue with wavpack DSD files
« Reply #3 on: 10 Dec '19 - 03:46 »
I don't seem to be able to reproduce that here. Do you have the latest Wavpack and DSD plugins installed? If so, perhaps another plugin is interfering. Does the problem still happen if you remove all other input plugins? If that stops it, please try putting them back one at a time to find the culprit.
Hi Ian.
Yes I have latest versions of everything (asio, wv, dsd plugins, and xmplay as well). I tried removing all plugins except dsd,wv and asio but still issue is present.
I thing I figured out a bit more.
So if I add new wv dsd file to the playlist and play it immediately (time is still not calculated for this file in the playlist, I just see - in that columng) it works fine.
But if I add new wv dsd file to the playlist and wait for 3-4 seconds (time will be updated in the playlist), it will not work, file will be skipped. After restart of xmplay, it works.

Also I noticed, when I add new wv dsd file to the playlist, it needs ~2-3 seconds to update time in playlist, but if I remove it from the playlist and add back again (without restarting xmplay), time is updated immediately. Not sure if this matters at all.

Ian @ un4seen

  • Administrator
  • Posts: 22396
Re: Issue with wavpack DSD files
« Reply #4 on: 10 Dec '19 - 17:16 »
Oh yes, I see the problem now (in the file info scanning). Here's an updated Wavpack plugin that should fix it:

   www.un4seen.com/stuff/xmp-wv.dll

Let me know if you still have the problem with that.

garson

  • Posts: 161
Re: Issue with wavpack DSD files
« Reply #5 on: 10 Dec '19 - 20:21 »
Ian,  you are awesome, as always.  :)
Issue is gone now, and file scanning is quicker now as well.  :)

Ian @ un4seen

  • Administrator
  • Posts: 22396
Re: Issue with wavpack DSD files
« Reply #6 on: 11 Dec '19 - 15:18 »
Great! The Wavpack plugin update (rev.6a) is now up on the XMPlay page.