Author Topic: XMPlay SID plugin  (Read 290747 times)

Fraggie

  • Posts: 710
Re: XMPlay SID plugin
« Reply #25 on: 21 Mar '05 - 16:12 »
New in beta 16:
 
 - added: Compute!'s sidplayer MUS format support
 - added: showing all subsongs times in general tab
 - fixed: crashing at halftime when playing in stereo
 - fixed: seeking when playing in stereo
 - fixed: crashing on very short songs
 

Fraggie

  • Posts: 710
Re: XMPlay SID plugin
« Reply #26 on: 22 Mar '05 - 16:53 »
New in beta 17:
 - added: stereo sidplayer support (MUS+STR)
 - added: fadeout
 - added: option to disable SID filter
 - fixed: more crashfixes

Keltic Danor

  • XMPlay Support
  • Posts: 747
Re: XMPlay SID plugin
« Reply #27 on: 22 Mar '05 - 21:50 »
New in beta 17:
 - added: stereo sidplayer support (MUS+STR)
 - added: fadeout
 - added: option to disable SID filter
 - fixed: more crashfixes
I'm not sure why but this version stops XMPlay from starting,wiping all settings did'nt resolve it. :-X

Also can we get a browse button for the SLDB location? :)

raina

  • Posts: 1163
Re: XMPlay SID plugin
« Reply #28 on: 23 Mar '05 - 09:27 »
I'm not sure why but this version stops XMPlay from starting

Good to know what caused it. In another words, the bug is confirmed here.
« Last Edit: 23 Mar '05 - 11:01 by raina »

Fraggie

  • Posts: 710
Re: XMPlay SID plugin
« Reply #29 on: 23 Mar '05 - 09:56 »
I can't tell what's wrong... It seems to be fine here. Are you sure it is SID plugin's fault?

Keltic Danor

  • XMPlay Support
  • Posts: 747
Re: XMPlay SID plugin
« Reply #30 on: 23 Mar '05 - 10:05 »
Only occurs when beta 17 is present, remove it and it's fine.

Interesting happenings:

- If its in the same dir as XMPlay, xmplay starts but shows no window, must be shut down via taskmanager. No erros

- If its in another dir. XMPlay will start and close straight away. No errors here either.

I'll go redownload 3.2.0.4, just to make extra sure I've got the latest and repost if there is any change.

raina

  • Posts: 1163
Re: XMPlay SID plugin
« Reply #31 on: 23 Mar '05 - 11:09 »
Are you sure it is SID plugin's fault?

Well, I downloaded beta 15 from the Support Site and overwrote beta 17. After that XMPlay started normally. That narrows it down a bit, I'd say. I'm running XP SP2.

Fraggie

  • Posts: 710
Re: XMPlay SID plugin
« Reply #32 on: 23 Mar '05 - 11:12 »
Okay, it should be sorted now.

raina

  • Posts: 1163
Re: XMPlay SID plugin
« Reply #33 on: 23 Mar '05 - 11:23 »
Okay, it should be sorted now.

Speedy. :) Will test it when I get home.

raina

  • Posts: 1163
Re: XMPlay SID plugin
« Reply #34 on: 23 Mar '05 - 15:49 »
Works fine now! I have to say it's a :)

Fraggie

  • Posts: 710
Re: XMPlay SID plugin
« Reply #35 on: 26 Mar '05 - 14:38 »
New in beta 18:
 - added: browse button for SLDB path
 - change: configuration can now be opened while playing
 - fixed: stupid "1/1" subsongs display
 - fixed: even more crashfixes

Fraggie

  • Posts: 710
Re: XMPlay SID plugin
« Reply #36 on: 2 Apr '05 - 11:12 »
New in beta 19:
 - STIL comments displaying (also for files outside HVSC dir)
 - many SLDB fixes
 - some memory leaks eliminated
 - 13 KB smaller ;D

Note that tags and STIL display will fail if text contains funky characters (like umlauts). It's going to be fixed when new XMPlay update becomes available.

raina

  • Posts: 1163
Re: XMPlay SID plugin
« Reply #37 on: 2 Apr '05 - 15:52 »
- STIL comments displaying (also for files outside HVSC dir)

Has anyone told you lately you rule?

Fraggie

  • Posts: 710
Re: XMPlay SID plugin
« Reply #38 on: 4 Apr '05 - 23:13 »
Has anyone told you lately you rule?
Nope. We - freeware programmers - get no appereciation. :P

New in beta 20:
 - STIL: added BUGList comments displaying
 - STIL: added Favourite Top 100 SIDs rank displaying
 - STIL: added comment configuration
 - STIL: some fixes here and there...
 - stereo panning (now you can use headphones ;D)
 - config reading bugfixed
 - workaround for the umlaut bug
 - setting up STIL or SLDB for the first time does no longer require restarting

You'll have to setup STIL again. Now point to a direcotry that contains STIL.txt, BUGList.txt and Creators.txt (usually HVSC/DOCUMENTS). As the HVSC may be archived, these files must not.
« Last Edit: 9 May '05 - 17:07 by Fraggie »

Zarggg

  • Posts: 1242
Re: XMPlay SID plugin
« Reply #39 on: 6 Apr '05 - 06:21 »
Fraggie... We love you. :D

raina

  • Posts: 1163
Re: XMPlay SID plugin
« Reply #40 on: 6 Apr '05 - 07:30 »
Yes.

Fraggie

  • Posts: 710
Re: XMPlay SID plugin
« Reply #41 on: 6 Apr '05 - 22:50 »
Fraggie... We love you. :D
You'd better!... :P

New in beta 21:
 - MOS8050 sids now work again... ::)
 - added: neat surround effect (you'll never going to switch back to mono ;D )
 - added: smooth (as baby's arse) fade-in to remove cracks at the beginning
 - still more bugfixes

Note that surround obviously works only in stereo mode. The size optimization is temporarily gone (until I find out why the 8050 sids stopped working).
« Last Edit: 6 Apr '05 - 23:14 by Fraggie »

FMsaziri

  • Posts: 2
Re: XMPlay SID plugin
« Reply #42 on: 8 Apr '05 - 20:53 »
My search for a state of the art sid plugin has ended at last...thanks Fraggie!!!  ;D ;D ;D

Ramosa

  • Guest
Re: XMPlay SID plugin
« Reply #43 on: 17 Apr '05 - 01:47 »
I keep all my SIDs in the zip file from the HVSC, because I know how slow my HD can be if I unpack all those tiny files.. So I just use winrar and then doubleclick inside the zip to open a file.

And I recently learned that it is no problem with the SID plugin to load both STIL info and Songlengths even if they are loaded from the zip.. But there is one tiny problem.. I can't playlist them!! The Zip plugin doesn't work this way, it only extracts all sid's form a zip to the playlist, and that really stalls XMPlay if you try it with the HVSC collection! :(

Any solution?

Fraggie

  • Posts: 710
Re: XMPlay SID plugin
« Reply #44 on: 9 May '05 - 17:19 »
And I recently learned that it is no problem with the SID plugin to load both STIL info and Songlengths even if they are loaded from the zip.. But there is one tiny problem.. I can't playlist them!! The Zip plugin doesn't work this way, it only extracts all sid's form a zip to the playlist, and that really stalls XMPlay if you try it with the HVSC collection! :(
Any solution?
You can always make a playlist manually... :)

New in BETA 22:
- MD5 calculator fixed
- smarter STIL loader (ie. badly-formatted-BUGList-proof :) )
- improved stability
- option to skip playing of sound effects
- option to filter out songs by the year of creation
- option to disable fade-out for sound effects
- option to add fade-out time to song length
- option to repeat short songs
- faster SLDB and STIL loading
- option to disable speed optimization
- option to disable anti-click fade-in
- many little bugs eliminated
- readme updated

Note that you need at least XMPlay v3.2.0.5 for this plugin to work correctly.

The 8SVX and ACM plugins have also been updated recently with some minor tweaks.
« Last Edit: 9 May '05 - 17:32 by Fraggie »

FMsaziri

  • Posts: 2
Re: XMPlay SID plugin
« Reply #45 on: 11 May '05 - 18:54 »
pieknyman.tk seems to be down.... :-\
« Last Edit: 11 May '05 - 18:56 by FMsaziri »

raina

  • Posts: 1163
Re: XMPlay SID plugin
« Reply #46 on: 11 May '05 - 22:47 »
pieknyman.tk seems to be down....  :-\
The Dot.tk domain is functional, it's xhost.info that's not working.

Fraggie

  • Posts: 710
Re: XMPlay SID plugin
« Reply #47 on: 12 May '05 - 10:40 »
The server is now online.

Changes in beta 22a:
- surround effect fixed (now it sounds like it was supposed to - the way nature intended ;D )
- some speed optimizations

piovrauz

  • Posts: 967
Re: XMPlay SID plugin
« Reply #48 on: 13 May '05 - 08:37 »
I've some question:

1) When playing sids in stereo, my P4 1.8Ghz jump at 45% of usage.
I need to know if it is a normal thing due to chip emulation, or something bad with my settings. I've discovered the sid universe 2 week ago, so it could be a odvious thing that I dont know.

2) When I seek, xmplay freeze and then restart after some time.
Same question that for n 1. By the way, could you add an option to disable seeking, so I'll don't seek for a bad click?

Thank you for the help, and for this great plugin of course!

PiovrauZ

Knurek

  • Posts: 523
Re: XMPlay SID plugin
« Reply #49 on: 13 May '05 - 10:03 »
1) When playing sids in stereo, my P4 1.8Ghz jump at 45% of usage.
I need to know if it is a normal thing due to chip emulation, or something bad with my settings. I've discovered the sid universe 2 week ago, so it could be a odvious thing that I dont know.

Naw, the stereo emulation is much slower due to (to my understanding) the fact that sidplay2 emulates two full C64s when playing in stereo. Those two have to be also frame-synched which should explain the overhead.
You may try the 'Optimize for speed' option. Might help you a bit (or just stick to mono, like C64 designers intended).

Quote
2) When I seek, xmplay freeze and then restart after some time.
Same question that for n 1.

As stated in the readme, seeking is slow. I don't think it will get faster, but Fraggie mentioned adding seeking progress indicator in the next version. We'll have to wait for that. :)