Author Topic: ! BUG: 3.3: Playing Non-Existant File Freezes XMPlay  (Read 5318 times)

Synetech

  • Posts: 129
Hi,

I can (more or less) reliably freeze XMPlay by playing a song, quitting XMPlay, moving or deleting the song so that as far as XMPlay is concerned, it does not exist, then running XMPlay and clicking Play.  XMPlay will say "opening..." and be frozen/unresponsive.  This does not ALWAYS happen, sometimes it will display the config panel overtop the main panel?! but it does happen a lot of the time when the file does not exist.

Ian @ un4seen

  • Administrator
  • Posts: 20437
Re: ! BUG: 3.3: Playing Non-Existant File Freezes XMPlay
« Reply #1 on: 17 Mar '06 - 16:37 »
I can't reproduce that here - it just puts a double red line through the track. You are talking about just a single (missing) track in the playlist, right? Is there a particular file/format that the problem happens with?

Of course, you are using the latest release? :)

Synetech

  • Posts: 129
Re: ! BUG: 3.3: Playing Non-Existant File Freezes XMPlay
« Reply #2 on: 17 Mar '06 - 20:41 »
I can't reproduce that here - it just puts a double red line through the track. You are talking about just a single (missing) track in the playlist, right? Is there a particular file/format that the problem happens with?

Of course, you are using the latest release? :)

Like I said, it doesn't do it all the time.  :(  I'm was using 3.3.0.2 and have updated to 3.3.0.3 now.  I'll keep an eye out to see if it happens again.  The config panel is still popping up though.  I've recorded a screencap to show it in action.
« Last Edit: 17 Mar '06 - 22:57 by Synetech »

Ian @ un4seen

  • Administrator
  • Posts: 20437
Re: ! BUG: 3.3: Playing Non-Existant File Freezes XMPlay
« Reply #3 on: 19 Mar '06 - 18:05 »
Nice bug report :)

Very strange too - I've never seen or heard of that happening before. What's the track entry's filename? Also, if you have any plugins, you could try removing them all.

Synetech

  • Posts: 129
Re: ! BUG: 3.3: Playing Non-Existant File Freezes XMPlay
« Reply #4 on: 20 Mar '06 - 00:39 »
I did some testing and narrowed down the config panel bug.

1: It only happens with skins that allow the config panel to be hidden.
2: It only happens when the in_txt plugin is loaded (looks like it's Denis Dubrov's problem)


As for XMPlay freezing when trying to open a non-existant file, it hasn't happened yet (I'm using 3.3.0.3 now.)  I'll keep an eye out.