XMPlay Last.fm/Audioscrobbler plugin (xmp-scrobbler)

Started by yagood,

raina

Quote from: KilliI do have one suggestion. I think it would be great if the plug-in could look up overrided tags from XMPlay's playlist. What do you think?
You can already submit overridden tags to Last.fm by enabling "Show overridden tags in Message info" from Options and stuff > Playlist.

yagood

Quote from: raina
Quote from: KilliI do have one suggestion. I think it would be great if the plug-in could look up overrided tags from XMPlay's playlist. What do you think?
You can already submit overridden tags to Last.fm by enabling "Show overridden tags in Message info" from Options and stuff > Playlist.

Yes, it works, but I think it still could be useful to have an option like "use overriden tags in submissions" in xmp-scrobbler. Or maybe not?

jv42

Hello !

Nice job making this plugin :-)

But I've got a little problem to report : sometimes, I've got this message :

QuoteSome tracks you submitted have not been added to your profile for the following reason:
Spam protection triggered: You submitted a track dated earlier than your last submission.

on Last.fm. I think it is related to having a big cache to submit (I had 24 tracks at the time, from what the log says).


I hope nobody reported this earlier, I confess I didn't read the whole thread  :-[

J.

yagood

Quote from: jv42
QuoteSome tracks you submitted have not been added to your profile for the following reason:
Spam protection triggered: You submitted a track dated earlier than your last submission.

Hmm,

on Last.fm. I think it is related to having a big cache to submit (I had 24 tracks at the time, from what the log says).

Hm, cache manager should submit these 24 tracks in packages of size 5, because Last.fm server doesn't like to be spammed with large amount of submissions. But I don't know why it triggered "track dated earlier...". Do you still have this event logged in your log file (xmp-scrobbler.txt in your XMPlay directory)? If yes, please attach it here on the forum, then I will have something to work with.

Quote from: jv42I hope nobody reported this earlier, I confess I didn't read the whole thread  :-[

This thread is a place where people can write about problems with xmp-scrobbler. You reported a problem so don't worry, sometimes it's even better when problem is reported a few times (although I don't recall yours being reported before) because then I know that it's a priority. Anyway, please provide a log if you can.

jv42

I've cut a piece of the log, from yersterday evening about the time of the error on Last.fm.

This spam message appeared already several times, each time a lot of tracks weren't yet submitted.
It seems the connection fails quite often (=> [LIBSCROBBLER] Submission failed: bad authorization.), thus the amount of files.

Hope this helps :-)

yagood

Quote from: jv42I've cut a piece of the log, from yersterday evening about the time of the error on Last.fm.

This spam message appeared already several times, each time a lot of tracks weren't yet submitted.
It seems the connection fails quite often (=> [LIBSCROBBLER] Submission failed: bad authorization.), thus the amount of files.

Hope this helps :-)

Thanks, I'll try to track down the problem, although I must say that I'm not sure why you get connection failures so often. Do you still have your cache file filled with submissions? If yes, please attach it too, I would want to have a look at it, maybe something is broken with generating cache.

jv42

No I don't have it anymore, afterwards the remaining submissions worked.

BTW, I forgot : I'm using XMPlay 3.3 and XMP-scrobbler v0.5 (not latest b - should I update ?)

yagood

Quote from: jv42No I don't have it anymore, afterwards the remaining submissions worked.

So how many submissions was lost (approx.)?

Quote from: jv42BTW, I forgot : I'm using XMPlay 3.3 and XMP-scrobbler v0.5 (not latest b - should I update ?)

Yes, you should update, although 0.5b won't help with any cache problems, because it contains only MusicBrainz fix.

yagood

OK, so I blocked XMPlay network access on my firewall to get ~20 submission cached, then unblocked it and all of them got sent fine. Cache manager works that way - every time you reach half of the properly tagged song, it tries to submit 5 songs (or less or just one if everything is going smooth and nothing gets cached). So in order to submit cache of size 20 you need to listen to 5 songs (4 will deal with 20 cached songs and fifth will deal with these 4). And it seems that it works fine, submits songs in the right order. But somehow you got this spam trigger with "dated earlier" message... I'll repeat my question for previous post - how many submissions actually haven't been sent to the Last.fm and haven't appeared on your profile page?

jv42

This last time, I think I lost one or two songs.
But a previous occurence removed nearly a whole album I had played. I'd say over 5 songs.

jv42

#190
It just happened again, I lost several songs, I'd say the 4 that were in cache, then the next submitted.

EDIT : I didn't lost the next submitted track, it shows on Last.fm now.

yagood

Quote from: jv42It just happened again, I lost several songs, I'd say the 4 that were in cache, then the next submitted.

EDIT : I didn't lost the next submitted track, it shows on Last.fm now.

Thanks for the log. What bothers me is that there's this...

2006-07-24 17:54:46   [LIBSCROBBLER] Preparing submit string - package size: 4

...which fails with "bad authorization", but then you closed XMPlay, reopened and...

2006-07-24 18:13:42   [CACHE] Number of entries in cache: 0

...so these 4 not submitted tracks haven't been written to the cache file (or have you deleted cache file between stopping and starting XMPlay?). I have an idea how to fix these "bad authorization" errors, but that's not the total solution, because even with such errors cached submissions should be handled properly - every track should get submitted at some point. I'll take a closer look at it and release a version with more debugging info produced in the log so I can gather more information about your situation... for now I can only say - sorry for inconvenience...

jv42

About this cache thing, I didn't mention, but I saw once in the log a message about a bad cache format, which I found strange considering I never used another version. But it doesn't seem to have any relation to the spam thing. I didn't delete the cache file.

Don't be sorry :) It's great to be able to use XMPlay with Last.fm, this is a minor issue ;)

yagood

Quote from: jv42About this cache thing, I didn't mention, but I saw once in the log a message about a bad cache format, which I found strange considering I never used another version. But it doesn't seem to have any relation to the spam thing. I didn't delete the cache file.

Message about bad cache format is strange indeed if you have never used previous versions of xmp-scrobbler. Well, I'll take a look at it. About cache file, hm, if you didn't delete it, then all I can say is "Houston, we have a bug". I'll try to release another version today.

Quote from: jv42Don't be sorry :) It's great to be able to use XMPlay with Last.fm, this is a minor issue ;)

Minor, but it should be fixed. Thanks for your help with it.

adscvr

Hello!!

I have a little problem with the plugin when it's behind a proxy server. The problem seems to be with the user and password. I put the proxy server, port, user and password but when it tries to connect to the internet returns an error saying that the proxy needs user and password. Here is the output:

[...]
2006-08-17 12:28:27 [DEBUG] DSP_SetFormat( 1, 44100, 2 )
2006-08-17 12:28:27 [DEBUG] XMP_SetTimer( 271 )
2006-08-17 12:28:27 [DEBUG] XMP_KillTimer
2006-08-17 12:28:27 [INFO] Next submission in 135 seconds... (xmpCounter = 11907000)
2006-08-17 12:28:27 [LIBSCROBBLER] The server reported a processing error.
2006-08-17 12:28:27 [LIBSCROBBLER] HTTP/1.1 407 Proxy Authentication Required ( The ISA Server requires authorization to fulfill the request. Access to the Web Proxy service is denied.  )


2006-08-17 12:28:27 [LIBSCROBBLER] Unable to handshake: sleeping...

At first i thought it was a very restrictive proxy server. But recently i installed the latest winamp with the following plugin: http://static.last.fm/plugins/audioscrobbler.wa.1.1.10.exe and it connected without problems to the internet (same proxy, port, user and password).

Any ideas?

yagood

Thanks for reporting this, it looks like we have a bug in setting proxy data. Could you please try attached version and report if it fixes this issue?

adscvr

Quote from: yagoodThanks for reporting this, it looks like we have a bug in setting proxy data. Could you please try attached version and report if it fixes this issue?

Thanks for the quick answer!!
Bad news is: the problem was not fixed... :(

yagood

Quote from: adscvrThanks for the quick answer!!
Bad news is: the problem was not fixed... :(

 :-[

Just to make sure - does "Using proxy server: XXX (with authentication - user and password are set in options)" appear in you log now with this new version? It should. Hmm, I will look deeper for the solution...

adscvr

Quote from: yagoodJust to make sure - does "Using proxy server: XXX (with authentication - user and password are set in options)" appear in you log now with this new version? It should. Hmm, I will look deeper for the solution...

I didn't see that. I tried disabling both options (proxy, authenticator) and then closed xmplay; then run xmplay again and enabled both. It just keep showing the same output i've sent before.

adscvr

This is the output:
2006-08-17 17:07:33 [LIBSCROBBLER] Using proxy server: ca-proxy2.br.bosch.com:8080
2006-08-17 17:07:33 [LIBSCROBBLER] ...

I cleared all the text boxes and saved. Then disabled proxy and authentication and closed xmplay. When executed again, i enabled the options and filled the proxy, port, user and password boxes. Saved and the above message again :(