Author Topic: ! XMP 3.3.0.5: Slow Startup / Unexplained File Reads  (Read 43348 times)

Ian @ un4seen

  • Administrator
  • Posts: 20426
Re: ! XMP 3.3.0.5: Slow Startup / Unexplained File Reads
« Reply #25 on: 22 Aug '06 - 13:31 »
Oh, and what happens if there is more than one plugin that can handle a filetype.  For example, what if you have the native XMP MIDI plugin present as well as the Winamp MIDI plugin (and perhaps, another one as well), or maybe two 3rd party plugins for something that there is no native support for.  Which one is used to render the song?

The plugins are tried in the order that they are listed in the "Plugins & Skins" options page, eg. native before Winamp. The built-in decoders (MOD/MPEG/OGG/WAV) are tried before any plugins.

Synetech

  • Posts: 129
Re: ! XMP 3.3.0.5: Slow Startup / Unexplained File Reads
« Reply #26 on: 23 Aug '06 - 00:18 »
The plugins are tried in the order that they are listed in the "Plugins & Skins" options page, eg. native before Winamp. The built-in decoders (MOD/MPEG/OGG/WAV) are tried before any plugins.

And there's no way to change it right?  I guess I'll just have to try to figure out which ones are better and remove the others.

Ian @ un4seen

  • Administrator
  • Posts: 20426
Re: ! XMP 3.3.0.5: Slow Startup / Unexplained File Reads
« Reply #27 on: 23 Aug '06 - 15:07 »
The plugins are tried in the order that they are listed in the "Plugins & Skins" options page, eg. native before Winamp. The built-in decoders (MOD/MPEG/OGG/WAV) are tried before any plugins.

And there's no way to change it right?

Nope, 'fraid not.

If you just want to reorder the Winamp plugins, you could search for and modify the plugin name in the DLLs.

Synetech

  • Posts: 129
Re: ! XMP 3.3.0.5: Slow Startup / Unexplained File Reads
« Reply #28 on: 23 Aug '06 - 17:07 »
Nah; only one will be used anyhow, so it's better to just take the least useful one out.  :)

samplah!

  • Posts: 99
Re: ! XMP 3.3.0.5: Slow Startup / Unexplained File Reads
« Reply #29 on: 24 Aug '06 - 23:40 »
Post moved. sorry  ::)
« Last Edit: 25 Aug '06 - 10:34 by sampler »

Synetech

  • Posts: 129
Re: ! XMP 3.3.0.5: Slow Startup / Unexplained File Reads
« Reply #30 on: 29 Aug '06 - 17:06 »
The plugins are tried in the order that they are listed in the "Plugins & Skins" options page, eg. native before Winamp. The built-in decoders (MOD/MPEG/OGG/WAV) are tried before any plugins.

Wait a second, where are the native plugins for MP3 and stuff?  How can we get XMP to use a 3rd party plugin for MP3, etc. instead of the XMP's native one?  I want to try a surround sound MP3 plugin but XMP won't let me.

Oh, and XMP's AC3 plugin doesn't do multichannel no matter what the setting, it insists on outputting to 2 speakers.

Tsorovan

  • Posts: 1247
Re: ! XMP 3.3.0.5: Slow Startup / Unexplained File Reads
« Reply #31 on: 30 Aug '06 - 08:46 »
How can we get XMP to use a 3rd party plugin for MP3, etc. instead of the XMP's native one?
You cannot.

Synetech

  • Posts: 129
Re: ! XMP 3.3.0.5: Slow Startup / Unexplained File Reads
« Reply #32 on: 30 Aug '06 - 09:24 »
How can we get XMP to use a 3rd party plugin for MP3, etc. instead of the XMP's native one?
You cannot.

Well that's a kick in the groin; XMP's MP3 plugin doesn't support surround sound MP3s and it's AC3 plugin doesn't output to multiple speakers.  :(

Rah'Dick

  • XMPlay Support
  • Posts: 932
Re: ! XMP 3.3.0.5: Slow Startup / Unexplained File Reads
« Reply #33 on: 30 Aug '06 - 12:00 »
What's with this?
http://support.xmplay.com/file_comment.php?id=523

[Edit] Just noticed that this is rather off-topic.
« Last Edit: 30 Aug '06 - 12:03 by Rah'Dick »

Synetech

  • Posts: 129
Re: ! XMP 3.3.0.5: Slow Startup / Unexplained File Reads
« Reply #34 on: 31 Aug '06 - 03:36 »
What's with this?
http://support.xmplay.com/file_comment.php?id=523

Yeah, I've got that, but it can't be used because XMPlay plays MP3s with it's own built-in MP3 renderer, and you can't override it to use a 3rd party MP3 plugin.


[Edit] Just noticed that this is rather off-topic.

Yes, it got a little off-topic once the original concern was mollified.

Dotpitch

  • Posts: 2871
Re: ! XMP 3.3.0.5: Slow Startup / Unexplained File Reads
« Reply #35 on: 31 Aug '06 - 09:44 »
What's with this?
http://support.xmplay.com/file_comment.php?id=523
Yeah, I've got that, but it can't be used because XMPlay plays MP3s with it's own built-in MP3 renderer, and you can't override it to use a 3rd party MP3 plugin.
You can. The file just has to make clear to XMPlay it's not a regular MP3 and can only be properly decoded by a plugin, just like MP3Pro files. Unfortunately, it looks like the MP3Surround-plugin doesn't work that way :-\.

Ian @ un4seen

  • Administrator
  • Posts: 20426
Re: ! XMP 3.3.0.5: Slow Startup / Unexplained File Reads
« Reply #36 on: 31 Aug '06 - 14:27 »
The plugins are tried in the order that they are listed in the "Plugins & Skins" options page, eg. native before Winamp. The built-in decoders (MOD/MPEG/OGG/WAV) are tried before any plugins.

Wait a second, where are the native plugins for MP3 and stuff?  How can we get XMP to use a 3rd party plugin for MP3, etc. instead of the XMP's native one?  I want to try a surround sound MP3 plugin but XMP won't let me.

As mentioned, the built-in formats (inc. MP3) have priority over any plugins, but XMPlay will detect MP3pro files and pass them onto the MP3pro plugin (if installed). Here's an update to try, which should do the same thing for MP3surround files (and the MP3surround plugin)...

   www.un4seen.com/stuff/xmplay.exe

Rah'Dick

  • XMPlay Support
  • Posts: 932
Re: ! XMP 3.3.0.5: Slow Startup / Unexplained File Reads
« Reply #37 on: 31 Aug '06 - 20:24 »
Great! I didn't know whether the plugin works - someone pointed it out to me and I just put it on the Support Site, assuming it works. I neither have a surround speaker system nor surround MP3s, so I couldn't test it.

Synetech

  • Posts: 129
Re: ! XMP 3.3.0.5: Slow Startup / Unexplained File Reads
« Reply #38 on: 1 Sep '06 - 00:18 »
As mentioned, the built-in formats (inc. MP3) have priority over any plugins, but XMPlay will detect MP3pro files and pass them onto the MP3pro plugin (if installed). Here's an update to try, which should do the same thing for MP3surround files (and the MP3surround plugin)...

Ah, I understand.

I tried it out but it didn't work.  I'll upload a sample song.

Ian @ un4seen

  • Administrator
  • Posts: 20426
Re: ! XMP 3.3.0.5: Slow Startup / Unexplained File Reads
« Reply #39 on: 1 Sep '06 - 13:47 »
Here's another one to try...

   www.un4seen.com/stuff/xmplay.exe

If you still have problems with some files, please upload them too.

Synetech

  • Posts: 129
Re: ! XMP 3.3.0.5: Slow Startup / Unexplained File Reads
« Reply #40 on: 1 Sep '06 - 18:25 »
No, it still doesn't work.  But don't worry about it.  I tried it in Winamp and it didn't work with that either (it crashed!  :P)

I guess the plugin is just bad (unless someone else has gotten it to work.)

For now, I'll just use the Fraunhofer IIS MP3 Surround player (which is only 5.53MB :)) for surround songs (all 6 of them).


Ian @ un4seen

  • Administrator
  • Posts: 20426
Re: ! XMP 3.3.0.5: Slow Startup / Unexplained File Reads
« Reply #41 on: 3 Sep '06 - 13:48 »
That's strange. The file you uploaded is playing fine here, using the MP3surround plugin from the support site. Are you using a different plugin version? Btw, when you say it "doesn't work", do you mean XMPlay still plays the MP3 itself, or it doesn't play at all?

What about the example files from all4mp3, can you play them? They're what I used to test the initial MP3surround update above.

Synetech

  • Posts: 129
Re: ! XMP 3.3.0.5: Slow Startup / Unexplained File Reads
« Reply #42 on: 3 Sep '06 - 18:36 »
Btw, when you say it "doesn't work", do you mean XMPlay still plays the MP3 itself, or it doesn't play at all?

Sorry, what I meant was that it wasn't playing surround, it still comes out of two speakers—other things were through.

What about the example files from all4mp3, can you play them? They're what I used to test the initial MP3surround update above.

I'll give those a try right now…

KEYGENMUSiC

  • Guest
Re: ! XMP 3.3.0.5: Slow Startup / Unexplained File Reads
« Reply #43 on: 20 Sep '06 - 06:05 »
3.3.0.5 won't paly this files http://rapidshare.de/files/33754987/xms.rar.html
3.3.0.4 plays them OK.

Ian @ un4seen

  • Administrator
  • Posts: 20426
Re: ! XMP 3.3.0.5: Slow Startup / Unexplained File Reads
« Reply #44 on: 23 Sep '06 - 12:38 »
They should be ok again now...

   www.un4seen.com/stuff/xmplay.exe

grep

  • Posts: 5
Re: ! XMP 3.3.0.5: Slow Startup / Unexplained File Reads
« Reply #45 on: 28 May '07 - 15:15 »
I've made some .BAT files to speed up XMPlay startup process.
http://www.4shared.com/file/16802703/249cba08/XMPlay_fast_startup.html
"xmplay_run.bat" - will play the last played track and then load rest of playlist.
"xmplay_sid.bat" - the same as above plus automatically restarts XMPlay if it crashed due to bug in XMP_SID.DLL.
Works on Windows 2000 or higher. Also requires nircmd http://www.nirsoft.net/utils/nircmd.html to hide console windows from taskbar.
Extract both ZIP files in XMPlay directory.
Bugs: The order of songs in playlist will be messed up somewhat.
Edit: That scripts work from time to time actually. I hope Ian will speed up XMPlay some day.
--- Size of my xmplay.pls is just 5 megabytes ;D , but XMPlay starts up ~25 seconds and eats 100% CPU on Athlon 3200+ . What a shame.
« Last Edit: 29 May '07 - 08:15 by grep »