Author Topic: BASS 2.4 beta  (Read 122324 times)

Ian @ un4seen

  • Administrator
  • Posts: 20437
BASS 2.4 beta
« on: 20 Dec '07 - 16:22 »
The 2.4 final releases are up on the BASS page now!

Remaining x64 tests...

BASS/BASSWMA:
   www.un4seen.com/stuff/bass24-x64.zip

BASS_FX:
   www.un4seen.com/filez/0/bass_fx24-x64.zip
« Last Edit: 2 Apr '08 - 17:05 by Ian @ un4seen »

radio42

  • Posts: 4576
Re: BASS 2.4 beta
« Reply #1 on: 20 Dec '07 - 17:05 »
14.03.2008: Version 2.4.0.0 final is out!

Please see the help file (.chm) for a complete list of changes and take a look to the "Upgrading from 2.3" section!
Note, that support for .Net 1.1 has been discontinued. Supported .Net Framework versions include 2.0, 3.0 and 3.5.

BASS.NET beta:
Full Install:
  www.un4seen.com/filez/4/Bass24.Net.zip

Lib only:
  www.un4seen.com/filez/4/Bass24.Net_update.zip

BASS_WADSP:
  www.un4seen.com/filez/4/bass_wadsp24.zip


Installer notes:
The provided samples are now installed to the <AppDataUser> directory!

« Last Edit: 14 Mar '08 - 13:39 by radio42 »

BassFan

  • Guest
Re: BASS 2.4 beta
« Reply #2 on: 20 Dec '07 - 20:00 »
Hi

i have a problem change the device for BASS_RecordGetInput with 2.4

Code: [Select]
procedure TfrmMain.ComboBox1Click(Sender: TObject);
var
  Volumelevel: single;
begin
 
  BASS_RecordGetInput(ComboBox1.ItemIndex, Volumelevel);
  LevelBar.Position := Trunc(Volumelevel * 100);
end;

Code: [Select]
procedure TfrmMain.LevelBarChange(Sender: TObject);
begin

  BASS_RecordSetInput(ComboBox1.ItemIndex, BASS_INPUT_ON, LevelBar.Position / 100);
  lblLevel.Caption := IntToStr(LevelBar.Position);
end;

1. problem
use Stereomix set VolumeLevel to 32 close my application and start a new instance
then my Slider set to 31 close my application and start a new instance
then my Slider set to 30 and so on
 
the value of BASS_RecordGetInput inc. run a new instance -1

i hope you can understand my english
 
german..
Habe da ein problem mit BASS_RecordGetInput

1. Der eingestellte Level wird richtig eingelesen und auch visualisiert
allerdings nur solange bis die anwendung neu gestartet wird danach incrementiert die automatisch
ohne das ich etwas verändert habe also immer um 1 und das bei jeden neustart der Anwendung.
Eingestellte Value 40 nach dem zehnten neustart sind es nur noch 30

greets

EDIT: problem solved
Error:
Code: [Select]
LevelBar.Position := Trunc(Volumelevel * 100);Fixed:
Code: [Select]
LevelBar.Position := Round(Volumelevel * 100);
Thanks to Radio42 has found this little bug
« Last Edit: 21 Dec '07 - 20:30 by BassFan »

BassFan

  • Guest
Re: BASS 2.4 beta
« Reply #3 on: 20 Dec '07 - 21:06 »
Error in VB API

Code: [Select]
Declare Function BASS_ChannelLock Lib "bass.dll" (ByVal handle As Long, ByVal lock As Long) As Longyou can not use
Quote
lock
in Vb as Parameter

Rename it to chLock or what ever

EDIT: problem solved
greets BassFan
« Last Edit: 22 Dec '07 - 12:28 by BassFan »

BassFan

  • Guest
Re: BASS 2.4 beta
« Reply #4 on: 20 Dec '07 - 21:12 »
Error in Delphi Sample RecordTest

EDIT: problem solved

greets BassFan
« Last Edit: 22 Dec '07 - 12:27 by BassFan »

SoundMike

  • Posts: 331
Re: BASS 2.4 beta
« Reply #5 on: 21 Dec '07 - 08:08 »
Ian,

Looking forward to using 2.4.

When 2.4 is issued on general release (ie ater beta trials completed), will BASSASIO also be issued on general release? I presume there are no changes so far to BASSASIO as it has not been included in the 2.4 files.

Regards,
Mike

Gamo

  • Posts: 97
Re: BASS 2.4 beta
« Reply #6 on: 21 Dec '07 - 10:34 »
Good job Ian,
   I got it work with my old code with some modification. I coding in VB6. (I used bass,bassmidi and bass_fx)

            chan = BASS_MIDI_StreamCreateFile64(BASSFALSE, FileName, 0, 0, 0, 0, BASS_MIDI_DECAYEND Or BASS_STREAM_DECODE, 0)

'            chan = BASS_MIDI_StreamCreateFile(BASSFALSE, FileName, 0, 0, BASS_MIDI_DECAYEND Or BASS_SAMPLE_SOFTWARE Or BASS_STREAM_DECODE, 0)

I got the problem with I try to call BASS_MIDI_StreamCreateFile it return error no. 5

The sound is better than bass 2.3.

Thank you

BassFan

  • Guest
Re: BASS 2.4 beta
« Reply #7 on: 21 Dec '07 - 10:48 »
Good job Ian,
   I got it work with my old code with some modification. I coding in VB6. (I used bass,bassmidi and bass_fx)

            chan = BASS_MIDI_StreamCreateFile64(BASSFALSE, FileName, 0, 0, 0, 0, BASS_MIDI_DECAYEND Or BASS_STREAM_DECODE, 0)

'            chan = BASS_MIDI_StreamCreateFile(BASSFALSE, FileName, 0, 0, BASS_MIDI_DECAYEND Or BASS_SAMPLE_SOFTWARE Or BASS_STREAM_DECODE, 0)

I got the problem with I try to call BASS_MIDI_StreamCreateFile it return error no. 5

The sound is better than bass 2.3.

Thank you


Hi use StrPtr for StreamCreateFile and read the helpfile of the new Lib ;)
Code: [Select]
chan = BASS_MIDI_StreamCreateFile(BASSFALSE, StrPtr(FileName), 0, 0, BASS_MIDI_DECAYEND Or BASS_SAMPLE_SOFTWARE Or BASS_STREAM_DECODE, 0)
greets BassFan

Gamo

  • Posts: 97
Re: BASS 2.4 beta
« Reply #8 on: 21 Dec '07 - 14:49 »
StrPtr is work for prjMidiTest but it does not work with my code.
I declare "filename" as string and assign string like this

filename = "c:\midi\test.mid"

More defect is the output of BASSMIDI is MONO.

Ian @ un4seen

  • Administrator
  • Posts: 20437
Re: BASS 2.4 beta
« Reply #9 on: 21 Dec '07 - 15:44 »
Error in VB API
...

Thanks for the fixes. They are now in the BASS download.

When 2.4 is issued on general release (ie ater beta trials completed), will BASSASIO also be issued on general release? I presume there are no changes so far to BASSASIO as it has not been included in the 2.4 files.

Yep, BASSASIO is unaffected by the BASS changes, apart from the included examples. I shall update those once the BASS 2.4 final is released.

More defect is the output of BASSMIDI is MONO.

Oops! A correction is in the BASSMIDI download now.

Andrew Jameson

  • Posts: 48
Re: BASS 2.4 beta
« Reply #10 on: 21 Dec '07 - 22:16 »
Hi,
Just noticed that I can download later beta versions !

I had an earlier beta and now I find, using the latest version, that the audio output is much quieter ... any ideas ?

Thanks

Andrew

Andrew Jameson

  • Posts: 48
Re: BASS 2.4 beta
« Reply #11 on: 21 Dec '07 - 22:20 »
Hi,
There's a typo in BassMidi.pas ...

BASS_MIDI_StreamCreateFile references FILEPROCS - shouldn't it be BASS_FILEPROCS ?

Andrew

cih997

  • Posts: 4
Re: BASS 2.4 beta
« Reply #12 on: 22 Dec '07 - 11:47 »
Hi,

when can we expect BASS AAC+ 2.4 beta version?

Ian @ un4seen

  • Administrator
  • Posts: 20437
Re: BASS 2.4 beta
« Reply #13 on: 22 Dec '07 - 14:41 »
I had an earlier beta and now I find, using the latest version, that the audio output is much quieter ... any ideas ?

Are you using the BASS_CONFIG_GVOL_STREAM option? If so, you may be using an old volume range. In earlier betas the range was 100 or 1000, but it is now 10000.

BASS_MIDI_StreamCreateFile references FILEPROCS - shouldn't it be BASS_FILEPROCS ?

Indeed, it should! A correction is now in the BASSMIDI download.

when can we expect BASS AAC+ 2.4 beta version?

I've put that up now (in the first post).

Andrew Jameson

  • Posts: 48
Re: BASS 2.4 beta
« Reply #14 on: 22 Dec '07 - 16:51 »
Thanks Ian,
Yes, I was using 1000 !

A quickie on Bass_MIDI.  I've found that most of my problems have been down to the quality of the midi files. One common problem that I've come across is where a controller parameter is outside the expected range - i.e. controller 7 with a parameter of 140 ... I think that this is channel volume - and what happens is that I suddenly find that the track is apparently muted ... I don't know what your approach is in Bass_MIDI but wouldn't it be better to cap the parameter at 127 ?

Andrew

mystreamradio

  • Posts: 12
Re: BASS 2.4 beta
« Reply #15 on: 23 Dec '07 - 02:24 »
Hello there,
First of all i would like to thank you all for this amazing library.
I have been using Bass in the last year or so, developing under c# vs.net 2005.
Everything is going very well, and I use this forum constantly, solving problems and debugging...
Using Bass.Net 2.3 , I had a problem running my program under Vista.
When I saw that 2.4 beta came out, I jumped on it, upgraded all my code to 2.4, and wished my Vista problem will be solved....
But I still have this problem ,and decided it is time to ask the experts..
After initilizing bass , i call this code to load WMA add-on :

//lets load the WMA add on
BassWma.LoadMe();  // basswma.dll must be in same directory
if (Bass.BASS_SetConfig(BASSConfig.BASS_CONFIG_WMA_PREBUF, 0) == false)
   {
    System.Windows.Forms.MessageBox.Show("Vista ERROR: " + Enum.GetName(typeof(BASSError), Bass.BASS_ErrorGetCode()));
    }

I have updated all my dll's to 2.4, and everything works fine in xp...
but running in vista i always get this error coming from the Bass.BASS_SetConfig(BASSConfig.BASS_CONFIG_WMA_PREBUF, 0) .
The error says :
"Vista ERROR : BASS_ERROR_ILLPARAM"

I added the vista,to be sure this is where it happens...
I cannot load or read wma correctly , but other then that all works well (bass itself loads and functions well)...

I would appriciate if anyone can help me solve this problem...I would like my program to run on vista...

Now since this post was not a 2.4 specific, I would like to tell you some more how nicely my upgrade from 2.3 to 2.4 went..
Everything went smooth, with just alittle code changes here and there.
1) I had a couple of int's changed into IntPtr. like mentioned by you.
2)Had to devide my volume value by 100 on ChannelSlideAttribute, ChannelSetAttribute (which now dropped their S at the end) , as now the range is from 0 (mute) to 1(full). Before to was from 0-100.
3) Had to change old flags to the new BassFlag Enum.
4) had to be sure to copy the new dll's......

took me all less then 20 minutes, and already started seeing things I like and will use..
So once again, thank you
Eli

radio42

  • Posts: 4576
Re: BASS 2.4 beta
« Reply #16 on: 23 Dec '07 - 11:29 »
I'll just tested it here under Vista...and I got no error codes at all. All working fine.
So there must be any other issue somewhere in your code.
When do you call BASS_SetConfig? Is this the first thing you are doing (even before BASS_Init)?

mystreamradio

  • Posts: 12
Re: BASS 2.4 beta
« Reply #17 on: 23 Dec '07 - 12:29 »
Hi Radio42,
first, thank you for your quick reply.
this is how I call bass, on the Form LOAD event :
BassNet.Registration("xxxxx", "xxxxx");

            // check the version..
            if (Utils.HighWord(Bass.BASS_GetVersion()) != Bass.BASSVERSION)
            {
                MessageBox.Show(this, "Wrong Bass Version!");
            }
                       
           

            if (Bass.BASS_Init(-1, 44100, BASSInit.BASS_DEVICE_DEFAULT, IntPtr.Zero , null))
            {
                Bass.BASS_SetConfig(BASSConfig.BASS_CONFIG_NET_PREBUF, 0); // so that we can display the buffering%

                //lets load the WMA add on
               
                //BassWma.LoadMe();  // basswma.dll must be in same directory
                if (BassWma.LoadMe() == false)
                {
                    System.Windows.Forms.MessageBox.Show("BASSWMALOAD ERROR: " + Enum.GetName(typeof(BASSError), Bass.BASS_ErrorGetCode()));
                }
                             

                if (Bass.BASS_SetConfig(BASSConfig.BASS_CONFIG_WMA_PREBUF, false) == false)
                {
                    System.Windows.Forms.MessageBox.Show("Vista ERROR: " + Enum.GetName(typeof(BASSError), Bass.BASS_ErrorGetCode()));
                }

                return true;
            }

this is how i init bass. I do have 2 dll's i have built using bass as well, and are refrenced in this project. maybe they call bass before the LOAD event of my main form????
Whats wierd is, it only happens to me on Vista ...and like I said Bass looks like it works good, just the wma fails.
I will try to write a small clean program, using the same LOAD event, see if it works...
please let me know if you have any other ideas.. gotto go to work, but will be back later today, and let this forum know if I do find anything...
tnxs again
Eli

Ian @ un4seen

  • Administrator
  • Posts: 20437
Re: BASS 2.4 beta
« Reply #18 on: 23 Dec '07 - 13:49 »
A quickie on Bass_MIDI.  I've found that most of my problems have been down to the quality of the midi files. One common problem that I've come across is where a controller parameter is outside the expected range - i.e. controller 7 with a parameter of 140 ... I think that this is channel volume - and what happens is that I suddenly find that the track is apparently muted ... I don't know what your approach is in Bass_MIDI but wouldn't it be better to cap the parameter at 127 ?

As controller parameters should be 7-bit, the 8th bit is simply ignored, eg. 140 would become 12. I'm not really sure which of capping or ignoring is the better option.

Btw, as a Delphi user, if you could update the MIDITEST example (to be like the C version), that would be handy :)

if (Bass.BASS_SetConfig(BASSConfig.BASS_CONFIG_WMA_PREBUF, 0) == false)

That reminds me. Contrary to what the docs currently state, the BASS_CONFIG_WMA_PREBUF option is actually disabled (FALSE) by default in the BASSWMA 2.4 beta. Instead of waiting for data in the stream creation or playback call, BASSWMA will instead just stall playback and automatically resume when the data arrives.

Andrew Jameson

  • Posts: 48
Re: BASS 2.4 beta
« Reply #19 on: 23 Dec '07 - 20:08 »
Hi Ian,
I thought I'd give the miditest a go - converting it to Delphi ...

I think that there's another declaration error in BassMidi.pas :

function BASS_MIDI_StreamGetMark(handle:HSTREAM; mtype:DWORD; count:DWORD; var fonts:BASS_MIDI_MARK): BOOL; stdcall; external bassmididll;


The current declaration :

function BASS_MIDI_StreamGetMarks(handle:HSTREAM; mtype:DWORD; var fonts:BASS_MIDI_MARK; count:DWORD): DWORD; stdcall; external bassmididll;

I think is wrong ... BASS_MIDI_StreamGetMarks isn't in the help and the parameter order of fonts / count is wrong.

Perhaps you could confirm this ?

Andrew

mystreamradio

  • Posts: 12
Re: BASS 2.4 beta
« Reply #20 on: 24 Dec '07 - 03:35 »
Hi there..
I am doing more testing on 2.4 & vista, encountering some more problems.
I am trying to create a mixer stream (BASS_Mixer_StreamCreate). While in windows xp all goes well, and my stream retrieves a value, under Vista, I always get a stream of 0.
I checked and rechecked my code, and could not understand why it works in xp, and not in Vista.
 I then went to the 2.4 samples, and picked the WinampDSP sample, which also creates a mixer stream.
Same thing happens, running the program in winxp gives me a value to the stream (just did a MessageBox.Show(_mixerStream)....
same program on Vista, shows me 0....
Is bassmix supporting windows Vista?
I will update if I find any solutions...
Regarding my latest problem, i just removed if (Bass.BASS_SetConfig(BASSConfig.BASS_CONFIG_WMA_PREBUF, 0) == false) , from my code, and all is well.

Other then that I believe I also have a problem with Vista, with wma tag reading.
While I have no problem reading mp3 tags, wma tags cannot be read (again only under vista, using 2.4 dll's). I look more into that, after I solve my first problem.

Again thank you for the great support.
Eli

radio42

  • Posts: 4576
Re: BASS 2.4 beta
« Reply #21 on: 24 Dec '07 - 10:58 »
Have you installed a WMA codec under Vista? (e.g. have you installed Windows Media Player 11)?

mystreamradio

  • Posts: 12
Re: BASS 2.4 beta
« Reply #22 on: 24 Dec '07 - 14:50 »
I have just verified, windows media player 11 is installed by default with vista, and does exist on the machine.. do I need to install the WMA codec, on top of the media player??? I believe if Media player is installed ,I do not need to install wma codec.

This has nothing to do with my mixer streams returning 0 on vista, correct??
any insights on that problem?
tnx
eli

P.S. I will open a new post for this issue, as it is not 2.4 specific problems, but more of a Vista problems.


Have you installed a WMA codec under Vista? (e.g. have you installed Windows Media Player 11)?

« Last Edit: 24 Dec '07 - 17:02 by mystreamradio »

Abrexxes

  • Posts: 25
Re: BASS 2.4 beta
« Reply #23 on: 25 Dec '07 - 09:38 »
Code: [Select]
Global Const BASS_MUSIC_SINCINTER = &H800000 ' sinc interpolated sample mixing
Global Const BASS_MUSIC_POSRESET = 32768  ' stop all notes when moving position <---?
Global Const BASS_MUSIC_POSRESETEX = &H400000

A little joke in the VB.bas?  ;D

firemen

  • Posts: 151
Re: BASS 2.4 beta
« Reply #24 on: 26 Dec '07 - 21:24 »
TmpChan:= BASS_MIDI_StreamCreateFile(FALSE, PChar(SourceFile), 0, 0, BASS_MUSIC_DECODE,0);

total:= BASS_MIDI_StreamGetMark(TmpChan, BASS_MIDI_MARK_LYRIC, myBASS_MIDI_MARK, 0);


old 2.3  all work,  2.4 return (total)  = 0   

:(